Bug 1565123 - Do not report Fatal errors as non-fatal
Summary: Do not report Fatal errors as non-fatal
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1398847
TreeView+ depends on / blocked
 
Reported: 2018-04-09 12:47 UTC by Jaroslav Mracek
Modified: 2018-06-28 12:10 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-28 12:10:52 UTC
Type: Bug


Attachments (Terms of Use)

Description Jaroslav Mracek 2018-04-09 12:47:52 UTC
Description of problem:
Do not report errors as nonfatal like in https://bugzilla.redhat.com/show_bug.cgi?id=1398847

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Jaroslav Mracek 2018-04-09 14:11:26 UTC
I create a patch that should solve the issue (https://github.com/rpm-software-management/dnf/pull/1052).

Comment 2 Bruce Jerrick 2018-06-22 05:52:49 UTC
(In reply to Jaroslav Mracek from comment #1)
> I create a patch that should solve the issue
> (https://github.com/rpm-software-management/dnf/pull/1052).

But it looks like that just changes the message; i.e., the installation will still abort.

Comment 3 Jaroslav Mracek 2018-06-28 12:10:52 UTC
Yes, if anything went terribly wrong the abort is good idea. The decision is made by rpm. 

The patch was release as part of dnf-3.0.1-1 into rawhide


Note You need to log in before you can comment on or make changes to this bug.