Bug 1565168 - [OSP13]Several different OSP deployment failures produce unrelated/misleading Error for ( response from Zaqar. Code: 503. )
Summary: [OSP13]Several different OSP deployment failures produce unrelated/misleading...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-zaqar
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: beta
: 13.0 (Queens)
Assignee: Thomas Hervé
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 14:27 UTC by Omri Hochman
Modified: 2018-06-27 13:51 UTC (History)
6 users (show)

Fixed In Version: openstack-zaqar-6.0.1-0.20180405023010.6357d69.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:50:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 555724 None stable/queens: MERGED zaqar: Fix claims on non-existing queue on swift (Ia92774ef1c55a371e37fc845511a5dceb8f92c00) 2018-04-16 13:13:04 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:51:34 UTC

Description Omri Hochman 2018-04-09 14:27:15 UTC
[OSP13]Several different OSP deployment failures produce unrelated/misleading Error for ( response from Zaqar. Code: 503. ) 


Environment: 
------------
puppet-zaqar-12.3.1-0.20180221093329.8b554f3.el7ost.noarch
python2-zaqarclient-1.9.0-1.el7ost.noarch
openstack-zaqar-6.0.1-0.20180302005413.4659f9b.el7ost.noarch
openstack-tripleo-heat-templates-8.0.2-0.20180327213843.f25e2d8.el7ost.noarch
instack-8.1.1-0.20180313084439.0d768a3.el7ost.noarch
instack-undercloud-8.4.0-2.el7ost.noarch


Description:
-------------
This error can be misleading for QE/GSS ( or anyone troubleshooting OSP), as we saw this log appear in several different ops13 failures,  the end results or root cause of the deployment failure usually was unrelated to this general ERROR for Zaqar. 


The solution should be a patch to reduce or eliminate those  Zaqar. Code: 503 errors when not relevant.


Example of failures with this error: 
-------------------------------------
https://bugzilla.redhat.com/show_bug.cgi?id=1552008 
https://bugzilla.redhat.com/show_bug.cgi?id=1559889
etc.. there are more..

Comment 4 Omri Hochman 2018-04-20 18:43:24 UTC
verified : unable to reproduce with
 openstack-zaqar-6.0.1-0.20180405023010.6357d69.el7ost.noarch

Comment 6 errata-xmlrpc 2018-06-27 13:50:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.