Bug 1565215 - Key migration to Barbican not handling backups
Summary: Key migration to Barbican not handling backups
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 13.0 (Queens)
Assignee: Alan Bishop
QA Contact: Avi Avraham
Kim Nylander
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 16:11 UTC by Alan Bishop
Modified: 2018-06-27 13:51 UTC (History)
2 users (show)

Fixed In Version: openstack-cinder-12.0.1-0.20180409184129.bc76abe.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:50:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 558906 None stable/queens: MERGED cinder: Handle migrating encryption key IDs in Backup table (Id4581eec80f82925c20c424847bff1baceda2349) 2018-04-10 17:22:38 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:51:34 UTC

Description Alan Bishop 2018-04-09 16:11:56 UTC
Description of problem:

When migrating encryption keys based on the ConfKeyManager's fixed_key to Barbican, entries in the Cinder backup table need to be migrated.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Create an encrypted volume using the ConfKeyManager
2. Create a backup of the volume
3. Update the deployment to Barbican and perform the Barbican key migration procedure

Actual results:

The encrypted volume's entry in the Backup table will still reference the all-zeros encryption_key_id associated with the ConfKeyMgr

Expected results:

The Backup table entry will have a Barbican encryption_key_id (not all zeros)

Additional info:

This issue has been fixed in stable/queens, and this BZ is to track testing the fix for OSP-13.

Comment 7 Avi Avraham 2018-05-03 12:05:03 UTC
Verified
RPM package version 
# docker exec -ti openstack-cinder-volume-docker-0 bash -c "rpm -q openstack-cinder"                               
openstack-cinder-12.0.1-0.20180418194613.c476898.el7ost.noarch

Verified according to steps describes in the bug description: 

1. Create an encrypted volume using the ConfKeyManager
2. Create a backup of the volume
3. Update the deployment to Barbican and perform the Barbican key migration procedure

Comment 9 errata-xmlrpc 2018-06-27 13:50:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.