Bug 1565230 - Suspend broken: "Freezing of tasks failed..."
Summary: Suspend broken: "Freezing of tasks failed..."
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 16:44 UTC by Paul DeStefano
Modified: 2018-04-10 14:53 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 14:53:38 UTC
Type: Bug


Attachments (Terms of Use)

Description Paul DeStefano 2018-04-09 16:44:15 UTC
Description of problem:
After upgrade to 4.15.14 (from 4.15.14), suspend is broken on Acer ES1-111


[41935.057157] Freezing user space processes ... (elapsed 0.005 seconds) done.
[41935.062563] OOM killer disabled.
[41935.062565] Freezing remaining freezable tasks ... 
[41955.080036] Freezing of tasks failed after 20.009 seconds (0 tasks refusing to freeze, wq_b
usy=1):
[41955.080052] Showing busy workqueues and worker pools:
[41955.080061] workqueue pm: flags=0x4
[41955.080067]   pwq 2: cpus=1 node=0 flags=0x0 nice=0 active=0/0
[41955.080090]     delayed: pm_runtime_work
[41955.080109]   pwq 0: cpus=0 node=0 flags=0x0 nice=0 active=0/0
[41955.080129]     delayed: pm_runtime_work, pm_runtime_work
[41955.080152] workqueue writeback: flags=0x4e
[41955.080156]   pwq 8: cpus=0-3 flags=0x4 nice=0 active=0/0
[41955.080173]     delayed: wb_workfn, wb_workfn
[41955.080198] workqueue usb_hub_wq: flags=0x4
[41955.080203]   pwq 0: cpus=0 node=0 flags=0x0 nice=0 active=2/0
[41955.080221]     in-flight: 90:hub_event hub_event
[41955.080261] pool 0: cpus=0 node=0 flags=0x0 nice=0 hung=0s workers=5 idle: 18688 16646 24286 18457
[41955.080571] Restarting kernel threads ... done.
[41955.081340] OOM killer enabled.
[41955.081344] Restarting tasks ... done.


Version-Release number of selected component (if applicable):
kernel-4.15.14-300.fc27.x86_64

How reproducible:
Always since 4.15.14

Steps to Reproduce:
1. Boot
2. Login to desktop
3. Fn-F4 or Session Menu > Suspend

Actual results:
System hangs for 20 seconds, then recovers.  Shows errors in bug description

Expected results:
Should suspend.  Never had this problem before.

Additional info:

Comment 1 Paul DeStefano 2018-04-09 21:20:00 UTC
Sorry, I meant upgrade from 4.15.13 to 4.15.14.  So, this bug was introduced in kernel 4.15.14 exactly.

Comment 2 Laura Abbott 2018-04-09 22:35:13 UTC
Can you see if 4.15.16 works https://koji.fedoraproject.org/koji/buildinfo?buildID=1067740 (I'll be filing this in bodhi shortly)

If that doesn't work, you can try a kernel bisect

Comment 3 Paul DeStefano 2018-04-10 03:36:09 UTC
Yes, I can do that! Thanks.

Regarding a bisect, I completely understand how that would help.  But, "try a kernel bisect" isn't enough to go on.  I link to Fedora instructions would be really helpful.

I've built many kernels, but that was 20 years ago.  It was grub 0.99 era.  A lot has changed.  Could you at least link to some official Fedora documentation for building one's own kernel and booting it?  I found a page on fedbisect, which is good, but I've forgotten some of these other things.

To Fedora's credit, I stopped practicing these skills because in the last 15 years, I've never had serious kernel bugs persist for more than a few kernel updates.

Comment 4 Paul DeStefano 2018-04-10 04:04:32 UTC
Success!  4.15.16 works and does not have any problems with suspend for me on my system.  Thank you, Laura.

Comment 5 Laura Abbott 2018-04-10 14:53:38 UTC
Thanks for letting us know.


Note You need to log in before you can comment on or make changes to this bug.