Bug 1565253 - Mouse cursor doubled on QEMU VNC on ppc64le
Summary: Mouse cursor doubled on QEMU VNC on ppc64le
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: 29
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1670530
TreeView+ depends on / blocked
 
Reported: 2018-04-09 18:19 UTC by Gustavo Luiz Duarte
Modified: 2019-05-05 02:43 UTC (History)
13 users (show)

Fixed In Version: libvirt-4.7.0-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1670530 (view as bug list)
Environment:
Last Closed: 2019-05-05 02:43:18 UTC
Type: Bug


Attachments (Terms of Use)
output of 'virsh dumpxml' (4.51 KB, text/plain)
2018-04-09 18:26 UTC, Gustavo Luiz Duarte
no flags Details

Description Gustavo Luiz Duarte 2018-04-09 18:19:00 UTC
Description of problem:

I'm using virt-install on POWER8 ppc64le bare metal with the following commmand line:

virt-install --name $NAME \
        --memory 8192 \
        --vcpus cores=1,threads=8 \
        --cdrom $ISO --os-variant fedora27 \
        --disk /var/lib/libvirt/images/${NAME}.img,size=50  \
        --graphics vnc,listen=$IP --noautoconsole \
        --input tablet 

I will attach the libvirt xml generated by the above command line.

The installation/Anaconda comes up... I can connect to the VNC, but I see two mouse cursors, which makes it hard to use, specially trying to reach the corner areas.

I've seen several posts about this issue on x86, which seems to be fixed by adding a usb tablet device. Just adding the tablet device doesn't seem to fix the issue on ppc64le.


Version-Release number of selected component (if applicable):

$ rpm -q qemu libvirt virt-install
qemu-2.10.1-3.fc27.ppc64le
libvirt-3.7.0-4.fc27.ppc64le
virt-install-1.4.3-2.fc27.noarch

Client:
tigervnc-1.8.0-5.fc27.x86_64

How reproducible:
Always

Comment 1 Gustavo Luiz Duarte 2018-04-09 18:26:57 UTC
Created attachment 1419506 [details]
output of 'virsh dumpxml'

Attached the output of 'virsh dumpxml' for the VM created with the virt-install command line from the bug description.

Comment 2 Gustavo Luiz Duarte 2018-04-09 18:34:16 UTC
I tried reproducing the qemu command line generated by libvirt... the qemu command line is something like:

/usr/bin/qemu-system-ppc64 -name guest=gld-test,debug-threads=on -S -machine pseries-2.10,accel=kvm,usb=off,dump-guest-core=off -m 8192 -realtime mlock=off
-smp 8,sockets=1,cores=1,threads=8 -uuid 41457ef7-faf5-4343-89f2-bc17fbf89a0b -no-user-config -nodefaults -rtc base=utc -no-reboot -boot strict=on
-device qemu-xhci,id=usb,bus=pci.0,addr=0x2 -device spapr-vscsi,id=scsi0,reg=0x2000 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x3
-drive file=/var/lib/libvirt/images/gld-test.img,format=qcow2,if=none,id=drive-virtio-disk0
-device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x4,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=2
-drive file=/isos/Fedora-Server-dvd-ppc64le-27-1.6.iso,format=raw,if=none,id=drive-scsi0-0-0-0,readonly=on
-device scsi-cd,bus=scsi0.0,channel=0,scsi-id=0,lun=0,drive=drive-scsi0-0-0-0,id=scsi0-0-0-0,bootindex=1
-netdev tap,fd=31,id=hostnet0,vhost=on,vhostfd=33 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:69:15:75,bus=pci.0,addr=0x1
-chardev pty,id=charserial0 -device spapr-vty,chardev=charserial0,reg=0x30000000
-chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channel/target/domain-29-gld-test/org.qemu.guest_agent.0,server,nowait
-device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=org.qemu.guest_agent.0 -device usb-tablet,id=input0,bus=usb.0,port=1
-device usb-kbd,id=input1,bus=usb.0,port=2 -device usb-mouse,id=input2,bus=usb.0,port=3 -vnc 9.40.192.114:1 -device VGA,id=video0,vgamem_mb=16,bus=pci.0,addr=0x7
-device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5 -object rng-random,id=objrng0,filename=/dev/urandom
-device virtio-rng-pci,rng=objrng0,id=rng0,bus=pci.0,addr=0x6 -msg timestamp=on


Removing the usb-mouse device ("-device usb-mouse,id=input2,bus=usb.0,port=3") from the qemu command line fixes the doubled mouse cursor issue... however, I can't find how to remove it from libvirt... I tried using 'virsh edit' and removing the following lines from the xml:

    <input type='mouse' bus='usb'>
      <alias name='input2'/>
      <address type='usb' bus='0' port='3'/>
    </input>

But libvirt doesn't seem to allow me to remove the default usb-mouse device.


[]'s
Gustavo

Comment 3 Ben Cotton 2018-11-27 16:16:21 UTC
This message is a reminder that Fedora 27 is nearing its end of life.
On 2018-Nov-30  Fedora will stop maintaining and issuing updates for
Fedora 27. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora  'version' of '27'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 27 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 4 Ben Cotton 2018-11-30 20:53:08 UTC
Fedora 27 changed to end-of-life (EOL) status on 2018-11-30. Fedora 27 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 5 Gustavo Luiz Duarte (IBM) 2019-01-29 18:40:22 UTC
I can still reproduce this on Fedora 29.

[]'s
Gustavo

Comment 6 Andrea Bolognani 2019-03-12 14:33:48 UTC
Patches merged upstream.

  commit 186bb479d0f409dc75175bea48a760838c479a6c
  Author: Andrea Bolognani <abologna@redhat.com>
  Date:   Wed Feb 27 18:41:35 2019 +0100

    qemu: Allow creating ppc64 guests with graphics and no USB mouse
    
    The existing behavior for ppc64 guests is to always add a USB
    keyboard and mouse combo if graphics are present; unfortunately,
    this means any attempt to use a USB tablet will cause both pointing
    devices to show up in the guest, which in turn will result in poor
    user experience.
    
    We can't just stop adding the USB mouse or start adding a USB tablet
    instead, because existing applications and users might rely on the
    current behavior; however, we can avoid adding the USB mouse if a USB
    tablet is already present, thus allowing users and applications to
    create guests that contain a single pointing device.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1683681
    
    Signed-off-by: Andrea Bolognani <abologna@redhat.com>
    Reviewed-by: Cole Robinson <crobinso@redhat.com>

v5.1.0-170-g186bb479d0

Comment 9 Fedora Update System 2019-04-02 16:25:49 UTC
libvirt-4.7.0-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b3bfc61567

Comment 10 Fedora Update System 2019-04-03 04:38:07 UTC
libvirt-4.7.0-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b3bfc61567

Comment 11 Fedora Update System 2019-05-05 02:43:18 UTC
libvirt-4.7.0-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.