Bug 1565288 - Customize Container Service Port Needs to Update Health Checks and Container
Summary: Customize Container Service Port Needs to Update Health Checks and Container
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 12.0 (Pike)
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: z5
: 13.0 (Queens)
Assignee: Martin Magr
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 19:16 UTC by Benjamin Schmaus
Modified: 2019-03-14 13:54 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.7-34.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-14 13:54:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1782369 0 None None None 2018-07-18 14:24:56 UTC
OpenStack gerrit 583629 0 None None None 2018-07-18 14:25:31 UTC
OpenStack gerrit 603387 0 None None None 2018-09-18 13:41:52 UTC
OpenStack gerrit 603391 0 None None None 2018-09-18 13:42:12 UTC
Red Hat Product Errata RHBA-2019:0448 0 None None None 2019-03-14 13:54:58 UTC

Description Benjamin Schmaus 2018-04-09 19:16:03 UTC
Description of problem:

In Director we can define a custom port for a overcloud service to run on, for example Redis.    However this defined port is not configured in the container or the health check.


Version-Release number of selected component (if applicable):
OSP12

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
Default port is used in container image and health check

Expected results:
Custom port defined in template should be applied via Ansible to running container environment and health check should be configured to check proper port

Additional info:

Comment 2 Steve Baker 2018-05-14 20:16:38 UTC
Assigning this healthcheck issue to DF:MetMon

Comment 23 errata-xmlrpc 2019-03-14 13:54:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0448


Note You need to log in before you can comment on or make changes to this bug.