Bug 1565291 - /var/log/dmesg <-- does not exist in RHAH 7.5 (rhel-dmesg.service)
Summary: /var/log/dmesg <-- does not exist in RHAH 7.5 (rhel-dmesg.service)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 19:26 UTC by Jon Disnard
Modified: 2018-12-19 21:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-11 15:35:27 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jon Disnard 2018-04-09 19:26:57 UTC
Description of problem:
/var/log/dmesg 
(doesn't exist)

Version-Release number of selected component (if applicable):


How reproducible:
In 7.5.0

Steps to Reproduce:
1. systemctl status rhel-dmesg
2. Shows dead
3. 

Actual results:
/var/log/dmesg does not exist


Expected results:
Per 7.4.x the file existed, and the systemd service was

Additional info:

Comment 2 Jon Disnard 2018-04-09 19:34:01 UTC
Actually, it's disputed if the systemd service was happy in 7.4.x, but regardless the file DID exist. /var/log/dmesg

So perhaps an overlap with rsyslogd? It's an open question.

Comment 3 Chris Negus 2018-05-14 00:28:21 UTC
My understanding is that /var/log/dmesg contains output from the kernel and kernel modules. So, it should be created when the kernel first boots up. My RHEL Atomic Host 7.5.1 system shows no such file. Although the kernel output is not shown in that file (since it doesn't exist), I can see the output by typing "dmesg". 

Is the fact that the file is not created a bug? If so, do you want us to tell people how to use the dmesg command to see that output?


Note You need to log in before you can comment on or make changes to this bug.