Bug 1565305 - 3.10 Installer fails - l_osm_session_secrets_slurp defined failed
Summary: 3.10 Installer fails - l_osm_session_secrets_slurp defined failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.10.0
Assignee: Michael Gugino
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 19:57 UTC by Vikas Laad
Modified: 2018-07-30 19:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:12:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:13:02 UTC

Description Vikas Laad 2018-04-09 19:57:57 UTC
Description of problem:
3.10 install fails with following error

  1. Hosts:    ec2-52-89-108-44.us-west-2.compute.amazonaws.com
     Play:     Inspect state of first master config settings
     Task:     Gather existing session secrets from first master
     Message:  The conditional check 'l_osm_session_secrets_slurp defined' failed. The error was: template error while templating string: expected token 'end of statement block', got 'defined'. String: {% if l_osm_session_secrets_slurp defined %} True {% else %} False {% endif %}
               
               The error appears to have been in '/root/openshift-ansible/roles/openshift_control_plane/tasks/generate_session_secrets.yml': line 18, column 3, but may
               be elsewhere in the file depending on the exact syntax problem.
               
               The offending line appears to be:
               
               # roles/lib_utils/filter_plugins/oo_filters.py
               - name: Gather existing session secrets from first master
                 ^ here

head on openshift-ansible master branch is
fe7e4702fe8654a3d97d218dd7250f1b938c3a7c

Version-Release number of the following components:
rpm -q ansible
ansible-2.4.3.0-1.el7ae.noarch

ansible --version
ansible 2.4.3.0
  config file = /root/openshift-ansible/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, Feb 20 2018, 09:19:12) [GCC 4.8.5 20150623 (Red Hat 4.8.5-28)]

How reproducible:
Always

Steps to Reproduce:
1. checkout openshift-ansible and deploy_cluster playbook see attached inventory file

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:
Install should complete

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 3 Michael Gugino 2018-04-09 20:18:11 UTC
PR Created: https://github.com/openshift/openshift-ansible/pull/7868

Comment 4 Vikas Laad 2018-04-11 12:59:26 UTC
works with latest code.

Comment 6 errata-xmlrpc 2018-07-30 19:12:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.