Bug 1565331 - Events tab: search bar/box is missing in 4.2 beta
Summary: Events tab: search bar/box is missing in 4.2 beta
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.0
Hardware: All
OS: All
high
high
Target Milestone: ovirt-4.2.3
: ---
Assignee: Alexander Wels
QA Contact: samuel macko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 20:34 UTC by Jason
Modified: 2019-06-26 06:00 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This release restores the ability to search Events.
Clone Of:
Environment:
Last Closed: 2018-05-15 17:48:41 UTC
oVirt Team: UX
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:49:12 UTC
oVirt gerrit 90062 0 master MERGED webadmin: Events search bar 2018-04-10 17:39:20 UTC
oVirt gerrit 90101 0 None None None 2018-04-11 18:23:18 UTC

Description Jason 2018-04-09 20:34:06 UTC
Description of problem:

The search bar that so many sites have come acustom to using appears to not be present in 4.2 beta. This will cause quite a stir/complaint as we now have our first complaint that it is missing. 

Version-Release number of selected component (if applicable):

4.2 Beta

How reproducible:

All the time

Steps to Reproduce:

Not present

Actual results:

Unable to perform a search in the UI as in all previous versions.

Expected results:

Being able to have a search bar like in prior versions.

Additional info:

Will attach sfdc case number and customer details in subsequent update.

Comment 1 Greg Sheremeta 2018-04-09 21:15:50 UTC
(In reply to Jason from comment #0)
> Description of problem:
> 
> The search bar ...  appears to not be present in 4.2 beta

We changed from a global search bar to one per page. When you go to VMs, you can search for VMs only. This is more in line with PatternFly, which we (almost) fully adopted in 4.2, and is being / has been adopted in all of our products.

Therefore, the global search bar will not be coming back.

However, it looks like we're missing a search for events. When you click Events in the left nav, that Events page should have a search. I'd call that a Regression.

Are there any other searches that are currently not possible in the UI?

cc'ing Tomas

Comment 2 Tomas Jelinek 2018-04-10 10:47:20 UTC
(In reply to Greg Sheremeta from comment #1)
> (In reply to Jason from comment #0)
> > Description of problem:
> > 
> > The search bar ...  appears to not be present in 4.2 beta
> 
> We changed from a global search bar to one per page. When you go to VMs, you
> can search for VMs only. This is more in line with PatternFly, which we
> (almost) fully adopted in 4.2, and is being / has been adopted in all of our
> products.
> 
> Therefore, the global search bar will not be coming back.
> 
> However, it looks like we're missing a search for events. When you click
> Events in the left nav, that Events page should have a search. I'd call that
> a Regression.

agree

> 
> Are there any other searches that are currently not possible in the UI?

I see the vnic profiles are also missing it, but they don't have the corresponding backend search so it has never worked. We could spin a separate BZ out of this one for the vnic profiles search, but it has way smaller priority than the events.

> 
> cc'ing Tomas

Comment 6 samuel macko 2018-04-19 11:19:54 UTC
Verified in ovirt version 4.2.3.2-0.1.el7.

Search bar in 'Events' tab is present.

Comment 10 errata-xmlrpc 2018-05-15 17:48:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 11 Franta Kust 2019-05-16 13:05:20 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.