Bug 1565370 - Rebase PCP for RHEL 7.6
Summary: Rebase PCP for RHEL 7.6
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcp   
(Show other bugs)
Version: 7.6
Hardware: All
OS: All
unspecified
medium
Target Milestone: rc
: ---
Assignee: Nathan Scott
QA Contact: Michal Kolar
Vladimír Slávik
URL:
Whiteboard:
Keywords: Rebase
Depends On:
Blocks: 1505884 1579881 1612916
TreeView+ depends on / blocked
 
Reported: 2018-04-09 23:34 UTC by Nathan Scott
Modified: 2018-10-30 09:41 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
_pcp_ rebased to version 4.1.0 The _pcp_ packages have been upgraded to upstream version of Performace Co-Pilot 4.1.0, which provides a number of bug fixes and enhancements over the previous version: * Added a sized-based interim compression to the `pmlogger_check(1)` script to reduce data volume sizes on systems configured via the `pcp-zeroconf` package. * Daily compressed archive metadata files. * Changed metric labels to first class PCP metric metadata. * Metric help text and labels are now stored in PCP archives. * Added more Linux kernel metrics: virtual machines, TTYs, aggregate interrupt and softirq counters, af_unix/udp/tcp connection (inet/ipv6), VFS locking, login sessions, AIO, capacity per block device, and other. * Performance Metrics Application Programming Interface (PMAPI) and the Performance Metrics Domain Agent (PMDA) API have been refactored, including promotion and deprecation of individual functions. * Added new virtual data optimizer (VDO) metrics to `pmdadm(1)`. * Improved integration with Zabbix agentd service with further low-level-discovery support in the `pcp2zabbix(1)` function. * Added a new PMDA `pmdabcc(1)` for exporting BCC and eBPF trace instrumentation. * Added a new PMDA `pmdaprometheus(1)` to consume metrics from Prometheus end-points.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-10-30 09:40:33 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3095 None None None 2018-10-30 09:41 UTC

Description Nathan Scott 2018-04-09 23:34:38 UTC
We've been asked to pull in new PCP Prometheus-related functionality in RHEL 7.6 - a rebase will be the way to go there.  This will also tackle the vast majority of open BZs for PCP on 7.6, which are fixed upstream in the pcp-4.x series.

We have observed only one (very) minor ABI issue with the Fedora pcp-4.x update several months ago, we do not expect this would realistically affect customers.

Comment 7 Nathan Scott 2018-08-14 21:34:34 UTC
OK, I've whittled the list down to 10.

Comment 10 Michal Kolar 2018-09-19 11:54:06 UTC
Verified against pcp-4.1.0-4.el7.

Comment 12 errata-xmlrpc 2018-10-30 09:40:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3095


Note You need to log in before you can comment on or make changes to this bug.