Bug 1565395 - FFU: running deploy_steps_playbook.yaml on a specific compute node fails with: FAILED! => {"msg": "Unexpected templating type error occurred on ({{ vars[item] | to_json }}): Undefined is not JSON serializable"}
Summary: FFU: running deploy_steps_playbook.yaml on a specific compute node fails with...
Keywords:
Status: CLOSED DUPLICATE of bug 1565374
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: beta
: ---
Assignee: Angus Thomas
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 00:22 UTC by Marius Cornea
Modified: 2018-04-10 17:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 17:46:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Marius Cornea 2018-04-10 00:22:28 UTC
Description of problem:
FFU: running deploy_steps_playbook.yaml on a specific compute node fails with: 

TASK [Render deployment file for 0] **********************************************************************************************************************************************************************************************************
fatal: [192.168.0.13]: FAILED! => {"msg": "Unexpected templating type error occurred on ({{ vars[item] | to_json }}): Undefined is not JSON serializable"}


Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-8.0.2-0.20180327213843.f25e2d8.el7ost.noarch

How reproducible:
100%
Steps to Reproduce:
1. Deploy OSP10:

openstack overcloud deploy --templates /usr/share/openstack-tripleo-heat-templates \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-management.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/tls-endpoints-public-ip.yaml \
-e ~/openstack_deployment/environments/enable-cpu-pinning.yaml \
-e ~/openstack_deployment/environments/nodes.yaml \
-e ~/openstack_deployment/environments/network-environment.yaml \
-e ~/openstack_deployment/environments/disk-layout.yaml \
-e ~/openstack_deployment/environments/public_vip.yaml \
-e ~/openstack_deployment/environments/enable-tls.yaml \
-e ~/openstack_deployment/environments/inject-trust-anchor.yaml \
-e ~/openstack_deployment/environments/scheduler_hints_env.yaml \
-e ~/openstack_deployment/environments/ips-from-pool-all.yaml \
-e ~/openstack_deployment/environments/neutron-settings.yaml \
-e ~/openstack_deployment/environments/custom_hiera.yaml \
--log-file overcloud_deployment.log &> overcloud_install.log

2. Upgrade undercloud to OSP11/12/13

3. Update stack outputs:

openstack overcloud deploy --templates /usr/share/openstack-tripleo-heat-templates \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-management.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/tls-endpoints-public-ip.yaml \
-e ~/openstack_deployment/environments/enable-cpu-pinning.yaml \
-e ~/openstack_deployment/environments/nodes.yaml \
-e ~/openstack_deployment/environments/network-environment.yaml \
-e ~/openstack_deployment/environments/disk-layout.yaml \
-e ~/openstack_deployment/environments/public_vip.yaml \
-e ~/openstack_deployment/environments/enable-tls.yaml \
-e ~/openstack_deployment/environments/inject-trust-anchor.yaml \
-e ~/openstack_deployment/environments/scheduler_hints_env.yaml \
-e ~/openstack_deployment/environments/ips-from-pool-all.yaml \
-e ~/openstack_deployment/environments/neutron-settings.yaml \
-e ~/openstack_deployment/environments/custom_hiera.yaml \
-e /home/stack/virt/docker-images.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/fast-forward-upgrade.yaml \
-e /home/stack/ffu_repos.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/config-download-environment.yaml \
-e /home/stack/ceph-ansible-env.yaml \

4. ansible-playbook --module-path /usr/share/ansible-modules/ -i /home/stack/tripleo-ansible-inventory-static.yaml -b /home/stack/tripleo-ureIl_-config/fast_forward_upgrade_playbook.yaml

5. Upgrade controllers:
ansible-playbook --module-path /usr/share/ansible-modules/ -i /home/stack/tripleo-ansible-inventory-static.yaml -b /home/stack/tripleo-z6Gps8-config/upgrade_steps_playbook.yaml --skip-tags=validation --limit=\!Compute
ansible-playbook --module-path /usr/share/ansible-modules/ -i /home/stack/tripleo-ansible-inventory-static.yaml -b /home/stack/tripleo-z6Gps8-config/deploy_steps_playbook.yaml --limit=\!Compute 

6. Upgrade compute-r01-01 compute node:
ansible-playbook --module-path /usr/share/ansible-modules/ -i /home/stack/tripleo-ansible-inventory-static.yaml -b /home/stack/tripleo-ureIl_-config/upgrade_steps_playbook.yaml --skip-tags=validation --limit=compute-r01-01 
nsible-playbook --module-path /usr/share/ansible-modules/ -i /home/stack/tripleo-ansible-inventory-static.yaml -b /home/stack/tripleo-ureIl_-config/deploy_steps_playbook.yaml --limit=compute-r01-01 

Actual results:
playbook fails:

TASK [Render deployment file for 1] **********************************************************************************************************************************************************************************************************
changed: [192.168.0.13]

TASK [Force remove deployed file for 1] ******************************************************************************************************************************************************************************************************
skipping: [192.168.0.13]

TASK [Run deployment 1] **********************************************************************************************************************************************************************************************************************
changed: [192.168.0.13]

TASK [Output for 1] **************************************************************************************************************************************************************************************************************************
ok: [192.168.0.13] => {
    "failed_when_result": false, 
    "msg": [
        {
            "stderr": [
                "[2018-04-10 00:11:39,029] (heat-config) [DEBUG] Running /usr/libexec/heat-config/hooks/script < /var/lib/heat-config/deployed/d18f2286-12da-4798-839f-27666b4ab972.json", 
                "[2018-04-10 00:11:39,073] (heat-config) [INFO] {\"deploy_stdout\": \"\", \"deploy_stderr\": \"\", \"deploy_status_code\": 0}", 
                "[2018-04-10 00:11:39,073] (heat-config) [DEBUG] [2018-04-10 00:11:39,063] (heat-config) [INFO] update_identifier=1523311974", 
                "[2018-04-10 00:11:39,063] (heat-config) [INFO] deploy_server_id=66d962e7-5a17-4f01-9f84-9a59c63220c1", 
                "[2018-04-10 00:11:39,063] (heat-config) [INFO] deploy_action=CREATE", 
                "[2018-04-10 00:11:39,063] (heat-config) [INFO] deploy_stack_id=overcloud-AllNodesDeploySteps-k7haujvwt2l4-ComputePostConfig-zjaemgzz33wc-ExtraDeployments-r2m4etjlhgvy-1-bllo4mjtznqg/936d84f8-7a42-409a-82ce-8abe0c319b64", 
                "[2018-04-10 00:11:39,063] (heat-config) [INFO] deploy_resource_name=TripleOSoftwareDeployment", 
                "[2018-04-10 00:11:39,063] (heat-config) [INFO] deploy_signal_transport=NO_SIGNAL", 
                "[2018-04-10 00:11:39,064] (heat-config) [DEBUG] Running /var/lib/heat-config/heat-config-script/d18f2286-12da-4798-839f-27666b4ab972", 
                "[2018-04-10 00:11:39,070] (heat-config) [INFO] ", 
                "[2018-04-10 00:11:39,070] (heat-config) [DEBUG] ", 
                "[2018-04-10 00:11:39,070] (heat-config) [INFO] Completed /var/lib/heat-config/heat-config-script/d18f2286-12da-4798-839f-27666b4ab972", 
                "", 
                "[2018-04-10 00:11:39,073] (heat-config) [INFO] Completed /usr/libexec/heat-config/hooks/script", 
                "[2018-04-10 00:11:39,074] (heat-config) [DEBUG] Running heat-config-notify /var/lib/heat-config/deployed/d18f2286-12da-4798-839f-27666b4ab972.json < /var/lib/heat-config/deployed/d18f2286-12da-4798-839f-27666b4ab972.notify.json", 
                "[2018-04-10 00:11:39,811] (heat-config) [INFO] ", 
                "[2018-04-10 00:11:39,811] (heat-config) [DEBUG] "
            ]
        }, 
        {
            "status_code": "0"
        }
    ]
}

TASK [Render deployment file for 0] **********************************************************************************************************************************************************************************************************
fatal: [192.168.0.13]: FAILED! => {"msg": "Unexpected templating type error occurred on ({{ vars[item] | to_json }}): Undefined is not JSON serializable"}


Expected results:
playbook runs without errors

Additional info:
Attaching the playbooks output, the error can be seen in ffu_deploy_steps_playbook_script_compute-r01-01.log.

Note: patches for BZ#1562479 were applied on this system.

Comment 2 Marius Cornea 2018-04-10 17:46:13 UTC

*** This bug has been marked as a duplicate of bug 1565374 ***


Note You need to log in before you can comment on or make changes to this bug.