Bug 1565402 - Xorg server aborts when composite extension is disabled
Summary: Xorg server aborts when composite extension is disabled
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 28
Hardware: All
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL: https://bugzilla.opensuse.org/show_bu...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 00:40 UTC by Felix Miata
Modified: 2019-03-11 21:58 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-11 21:58:05 UTC


Attachments (Terms of Use)
F28 coredump from running 4.16.6 kernel and Xorg server 1.19.6-8 (1.85 MB, application/octet-stream)
2018-05-06 04:25 UTC, Felix Miata
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 104993 None None None 2018-04-10 00:40:10 UTC

Description Felix Miata 2018-04-10 00:40:10 UTC
Xorg server aborts when composite extension is disabled

Steps to Reproduce:
1.Put the following somewhere in /etc/X11/xorg.conf.d/:
 	Section "Extensions"
	        Option          "Composite" "Disable"
	EndSection
2.Try to run Xorg

Actual results:
Xorg crashes

Expected results:
Xorg does not crash

Comment 1 Felix Miata 2018-04-25 02:02:47 UTC
Upstream bug was marked fixed several days ago, long after "last updated" 2018-04-09 20:40 EDT and F28's server 1.19.6-7 was posted to mirrors on 12 April, so crashing remains.

Comment 2 Felix Miata 2018-05-06 04:25:12 UTC
Created attachment 1432226 [details]
F28 coredump from running 4.16.6 kernel and Xorg server 1.19.6-8

Comment 3 Felix Miata 2018-06-16 04:15:38 UTC
27 used to be OK, but not for several months, same as 28.

Comment 4 Adam Jackson 2018-06-18 15:57:30 UTC
xorg-x11 hasn't been a real component since like FC4.

Why do you think disabling Composite is a thing you need to do?

Comment 5 Felix Miata 2018-06-18 17:32:43 UTC
Personal computing devices are expected to be personalized. Motion and fuzziness that KDE developers and others seem to think are cool or enhancements are annoying, often detracting from usability or accessibility. It seems like a waste to permit resources to be consumed by them. Shutting them off globally seems the most efficient way to eradicate them.

Comment 6 Felix Miata 2018-08-20 09:22:04 UTC
Server 1.20.1 in F29 works as expected.

Comment 7 Felix Miata 2019-03-11 21:58:05 UTC
This is gone in F29 and F30.


Note You need to log in before you can comment on or make changes to this bug.