Bug 1565477 - RHVH (RHVH-4.1-20180409.1-RHVH-x86_64-dvd1.iso) install failed.
Summary: RHVH (RHVH-4.1-20180409.1-RHVH-x86_64-dvd1.iso) install failed.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: Installation & Update
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ovirt-4.1.9
: ---
Assignee: Ryan Barry
QA Contact: Wei Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 06:00 UTC by Wei Wang
Modified: 2018-04-30 08:00 UTC (History)
9 users (show)

Fixed In Version: imgbased-0.9.58
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-30 08:00:19 UTC
oVirt Team: Node
rule-engine: ovirt-4.1+
rule-engine: blocker+
cshao: testing_ack+


Attachments (Terms of Use)
Install fail with iso(picture) (93.19 KB, image/png)
2018-04-10 06:00 UTC, Wei Wang
no flags Details
log files for iso installation (159.42 KB, application/x-gzip)
2018-04-10 06:01 UTC, Wei Wang
no flags Details
log files for ks installation (2.90 KB, application/x-gzip)
2018-04-10 06:02 UTC, Wei Wang
no flags Details

Description Wei Wang 2018-04-10 06:00:16 UTC
Created attachment 1419692 [details]
Install fail with iso(picture)

Description of problem:
RHVH-4.1-20180409.1-RHVH-x86_64-dvd1.iso install failed. Besides, install redhat-virtualization-host-4.1-20180409.0.x86_64.liveimg.squashfs with kickstart also fail.

Version-Release number of selected component (if applicable):
RHVH-4.1-20180409.1-RHVH-x86_64-dvd1.iso

How reproducible:
100%


Steps to Reproduce:
1. Clean install RHVH-4.1-20180409.1-RHVH-x86_64-dvd1.iso with anaconda
2. Check the post-script part during installation.


Actual results:
RHVH install failed no matter with anaconda or kickstart.

Expected results:
RHVH should be installed successfully no matter with anaconda or kickstart.


Additional info:
RHVH also install failed with kickstart (redhat-virtualization-host-4.1-20180409.0.x86_64.liveimg.squashfs).

Comment 1 Wei Wang 2018-04-10 06:01:38 UTC
Created attachment 1419693 [details]
log files for iso installation

Comment 2 Wei Wang 2018-04-10 06:02:27 UTC
Created attachment 1419694 [details]
log files for ks installation

Comment 3 Yaniv Kaul 2018-04-10 06:27:58 UTC
Relevant exception seems to be:
2018-04-09 23:38:04,197 [INFO] (migrate_etc) Migrating /etc (from <LV 'rhvh/rhvh-4.1-0.20180409.0+1' />)
2018-04-09 23:38:04,918 [INFO] (migrate_etc) Migrating /root
2018-04-09 23:38:04,921 [INFO] (fix_systemd_services) Syncing systemd levels
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/imgbased/utils.py", line 1484, in thread_group_handler
    t.join_with_exceptions()
  File "/usr/lib/python2.7/site-packages/imgbased/utils.py", line 1476, in join_with_exceptions
    raise exc[1]
CalledProcessError: Command '['rmdir', u'/tmp/mnt.buqJ2']' returned non-zero exit status 1
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/imgbased/utils.py", line 1484, in thread_group_handler
    t.join_with_exceptions()
  File "/usr/lib/python2.7/site-packages/imgbased/utils.py", line 1476, in join_with_exceptions
    raise exc[1]
CalledProcessError: Command '['rmdir', u'/tmp/mnt.QhLTM']' returned non-zero exit status 1
2018-04-09 23:38:09,392 [ERROR] (MainThread) Failed to migrate etc
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/imgbased/plugins/osupdater.py", line 120, in on_new_layer
    thread_group_handler(threads)
  File "/usr/lib/python2.7/site-packages/imgbased/utils.py", line 1487, in thread_group_handler
    sys.exit(1)
SystemExit: 1
Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/lib/python2.7/site-packages/imgbased/__main__.py", line 53, in <module>
    CliApplication()
  File "/usr/lib/python2.7/site-packages/imgbased/__init__.py", line 82, in CliApplication
    app.hooks.emit("post-arg-parse", args)
  File "/usr/lib/python2.7/site-packages/imgbased/hooks.py", line 120, in emit
    cb(self.context, *args)
  File "/usr/lib/python2.7/site-packages/imgbased/plugins/core.py", line 173, in post_argparse
    layout.initialize(args.source, args.init_nvr)
  File "/usr/lib/python2.7/site-packages/imgbased/plugins/core.py", line 220, in initialize
    self.app.imgbase.init_layout_from(source, init_nvr)
  File "/usr/lib/python2.7/site-packages/imgbased/imgbase.py", line 292, in init_layout_from
    self.add_layer(initial_base, new_layer)
  File "/usr/lib/python2.7/site-packages/imgbased/imgbase.py", line 191, in add_layer
    self.hooks.emit("new-layer-added", prev_lv, new_lv)
  File "/usr/lib/python2.7/site-packages/imgbased/hooks.py", line 120, in emit
    cb(self.context, *args)
  File "/usr/lib/python2.7/site-packages/imgbased/plugins/osupdater.py", line 123, in on_new_layer
    raise ConfigMigrationError()
imgbased.plugins.osupdater.ConfigMigrationError

Comment 4 Red Hat Bugzilla Rules Engine 2018-04-10 09:37:06 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 5 Wei Wang 2018-04-11 06:59:11 UTC
Test Version:
RHVH-4.1-20180410.0-RHVH-x86_64-dvd1.iso

Test Steps
1. Clean install RHVH-4.1-20180410.0-RHVH-x86_64-dvd1.iso with anaconda
2. Check the post-script part during installation.


Result:
RHVH install successfully no matter with anaconda or kickstart.


The bug has fixed, change the status to VERIFIED.

Comment 6 Sandro Bonazzola 2018-04-30 08:00:19 UTC
Closing the bug since 4.1.9 has been released.


Note You need to log in before you can comment on or make changes to this bug.