Bug 1565483 - review_before_build generates many deprecation warnings on templates
Summary: review_before_build generates many deprecation warnings on templates
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning Templates
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Released
Assignee: satellite6-bugs
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2018-04-10 06:26 UTC by Peter Vreman
Modified: 2019-10-07 17:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-21 23:21:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
review_before_build_debug_log (25.30 KB, text/plain)
2019-02-04 09:23 UTC, Roman Plevka
no flags Details

Description Peter Vreman 2018-04-10 06:26:18 UTC
Description of problem:

When enabling Build on a Host a review step is done.
This generates many 'DEPRECATION WARNING' messages that makes me worrying about potential issues, taht in fact does not exists

-------------
2018-04-10 06:18:09 ad462891 [app] [I] Processing by HostsController#review_before_build as */*
...
2018-04-10 06:18:10 ad462891 [app] [I] Rendering Kickstart default iPXE
2018-04-10 06:18:10 ad462891 [templates] [I] Rendering template 'Kickstart default'
2018-04-10 06:18:10 ad462891 [templates] [I] Rendering template 'Kickstart default iPXE'
2018-04-10 06:18:10 ad462891 [app] [I] Rendering Satellite Kickstart Default
2018-04-10 06:18:10 ad462891 [templates] [I] Rendering template 'Kickstart default'
2018-04-10 06:18:10 ad462891 [templates] [I] Rendering template 'Satellite Kickstart Default'
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.params in a template, it will be removed in 1.17. Use host_pa
ram instead.
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.params in a template, it will be removed in 1.17. Use host_pa
ram instead.
2018-04-10 06:18:10 ad462891 [templates] [I] Rendering template 'Kickstart default'
2018-04-10 06:18:10 ad462891 [templates] [I] Rendering template 'kickstart_networking_setup'
2018-04-10 06:18:10 ad462891 [templates] [I] Rendering template 'kickstart_ifcfg_get_identifier_names'
2018-04-10 06:18:10 ad462891 [templates] [I] Rendering template 'kickstart_ifcfg_generic_interface'
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.params in a template, it will be removed in 1.17. Use host_pa
ram instead.
2018-04-10 06:18:10 ad462891 [templates] [I] Rendering template 'subscription_manager_registration'
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.params in a template, it will be removed in 1.17. Use host_pa
ram instead.
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.params in a template, it will be removed in 1.17. Use host_pa
ram instead.
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.info in a template, it will be removed in 1.17. Use host_enc
instead.
2018-04-10 06:18:10 ad462891 [templates] [I] Rendering template 'remote_execution_ssh_keys'
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.params in a template, it will be removed in 1.17. Use host_pa
ram instead.
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.params in a template, it will be removed in 1.17. Use host_pa
ram instead.
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.param_true? in a template, it will be removed in 1.17. Use ho
st_param_true? instead.
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.params in a template, it will be removed in 1.17. Use host_pa
ram instead.
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.params in a template, it will be removed in 1.17. Use host_pa
ram instead.
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.params in a template, it will be removed in 1.17. Use host_pa
ram instead.
2018-04-10 06:18:10 ad462891 [templates] [I] Rendering template 'puppet_setup'
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.param_true? in a template, it will be removed in 1.17. Use ho
st_param_true? instead.
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.params in a template, it will be removed in 1.17. Use host_pa
ram instead.
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.param_true? in a template, it will be removed in 1.17. Use ho
st_param_true? instead.
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.params in a template, it will be removed in 1.17. Use host_pa
ram instead.
2018-04-10 06:18:10 ad462891 [templates] [I] Rendering template 'puppet.conf'
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.param_true? in a template, it will be removed in 1.17. Use ho
st_param_true? instead.
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.params in a template, it will be removed in 1.17. Use host_pa
ram instead.
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.param_true? in a template, it will be removed in 1.17. Use ho
st_param_true? instead.
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.params in a template, it will be removed in 1.17. Use host_pa
ram instead.
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.param_true? in a template, it will be removed in 1.17. Use ho
st_param_true? instead.
2018-04-10 06:18:10 ad462891 [app] [W] DEPRECATION WARNING: you are using deprecated @host.params in a template, it will be removed in 1.17. Use host_pa
ram instead.
2018-04-10 06:18:10 ad462891 [templates] [I] Rendering template 'ansible_provisioning_callback'
2018-04-10 06:18:10 ad462891 [app] [I] Rendering Satellite Kickstart Default Finish
2018-04-10 06:18:10 ad462891 [templates] [I] Rendering template 'Kickstart default'

[Unknown Hilti Tier] root@li-lc-1578:~# grep -c 'DEPRECATION WARNING:' /var/log/foreman/production.log
62
-------------

With Sat6.3 i expect these warnings to be either fixed in the tempaltes or hidden for me as a user, because there will be no foreman 1.17 in Sat6.3.x lifetime.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Marek Hulan 2018-04-10 17:36:29 UTC
Not sure if there's any action item for engineering. Warnings will disappear in 6.4 as the old method won't be available anymore. All uses of it will be replaced in all default templates. I understand that 1.17 version does not tell much to less technical users, but I guess you understand, that it means some upcoming version of Satellite.

Comment 3 Ondřej Pražák 2018-09-25 11:08:53 UTC
Deprecations have been removed and they no longer appear in 6.4, could QE verify?

Comment 4 Peter Vreman 2018-10-18 15:04:35 UTC
Confirmed that i did not see it on 6.4Beta

Comment 5 Peter Vreman 2018-11-02 14:13:48 UTC
Brad,

Confirmed that it is fixed in 6.4.0.
BZ can be closed

Peter

Comment 7 Roman Plevka 2019-02-04 09:23:33 UTC
Created attachment 1526696 [details]
review_before_build_debug_log

VERIFIED
on sat6.5.0-14

- I also attached a production log (DEBUG level) showing the generated logs for "review before build" step.
No deprecation warnings appeared

Comment 8 Brad Buckingham 2019-02-21 23:21:07 UTC
Thanks Peter!!

Moving this to CLOSED:CURRENTRELEASE as it was verified on 6.4.

Note: it has also since been verified on 6.5 internal builds.


Note You need to log in before you can comment on or make changes to this bug.