Bug 1565490 - volume alerts ambiguity
Summary: volume alerts ambiguity
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-gluster-integration
Version: rhgs-3.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Shubhendu Tripathi
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 06:38 UTC by Lubos Trilety
Modified: 2019-05-08 17:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-08 15:53:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
volume alert example (154.33 KB, image/png)
2018-04-10 06:38 UTC, Lubos Trilety
no flags Details

Description Lubos Trilety 2018-04-10 06:38:53 UTC
Created attachment 1419701 [details]
volume alert example

Description of problem:
It doesn't need to be clear with which volume a displayed alert is related as there is only volume name mentioned. Such information is not enough if several gluster trusted storage pools (clusters) are connected to RHGSWA with the same volume name(s).


Version-Release number of selected component (if applicable):
tendrl-ui-1.6.1-3.el7rhgs.noarch


How reproducible:
100%


Steps to Reproduce:
1. import several clusters with the same volume(s)
2. invoke some volume alert - e.g. stop the volume
3.


Actual results:
A new alert is displayed:
State of volume: <volume_name> changed from up to down
It's not clear which volume it is as there are several with the same name.


Expected results:
Part of any alert message should be some unique identifier, unique over all set-up/clusters. E.g. cluster name (if possible the short version) with volume name


Additional info:
The issue is on UI only as cluster name and integration id is part of API response.
e.g.
alert_type	STATUS
hash	a2955d3c2b10fa6028a26fd24b1fab58
classification	["cluster"]
node_id	
tags	{…}
integration_id	4df69949-9a2e-46aa-a174-c82a37df9a89
volume_name	volume_gama_disperse_4_plus_2x2
cluster_name	gluster-086635ac97de8067f044a7d5410736038c6a9326f93713b00b4e1ab2b49adbaf
volume_id	46d39e4f-77b5-41f8-9811-333e22bfd814
message	State of volume: volume_gama_disperse_4_plus_2x2 changed from up to down
plugin_instance	volume_volume_gama_disperse_4_plus_2x2
resource	volume_state
...

Comment 1 Ju Lim 2018-04-13 11:06:22 UTC
To make the volume name unique, we will need to add the cluster name so that the volume can be identified especially if it's possible that the same volume name can appear in multiple clusters.

Comment 2 Ju Lim 2018-04-13 11:13:11 UTC
Given current example of the message, I would suggest the following:

<volume> in <cluster> is <status>

Therefore, it would be:

volume_gama_disperse_4_plus_2x2 in 4d69949-9a2 is down

Note: the 4d69949-9a2 should be the full name of the cluster but I can't tell from the screenshot what the full cluster name is.  Ideally, the cluster-name would have a user-friendly short cluster name.

For more information about recommendations on the alert messages, take a look at https://docs.google.com/document/d/138SFPUlRqdLjISMcd-Cts-vWzY7wfTGWi8GhdQHnh0Q/edit?usp=sharing.


Note You need to log in before you can comment on or make changes to this bug.