Bug 1565499 - [RFE] Ibus emoji dialog cannot input multiple emoji annotations
Summary: [RFE] Ibus emoji dialog cannot input multiple emoji annotations
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 07:11 UTC by Pooja Yadav
Modified: 2018-07-20 02:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-20 02:18:35 UTC
Type: Bug


Attachments (Terms of Use)
Engine's lookup table (26.23 KB, image/png)
2018-04-11 09:35 UTC, fujiwara
no flags Details

Description Pooja Yadav 2018-04-10 07:11:56 UTC
Description of problem:
ibus emoji dialog box closes after selecting one emoji only, need to launch it again if we need to select another emoji.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Launch ibus emoji dialog using ibus emoji or ctrl-shift-e.
2. Search for a emoji and select it.
3. After selecting the emoji, dialog box closes

Actual results:
Dialog box closes after selecting one emoji

Expected results:


Additional info:
Ibus emoji should box should remain open if we haven't closed it, so that we don't have to open it again if we want to select more than one emoji.

Comment 1 fujiwara 2018-04-11 01:48:52 UTC
(In reply to Pooja Yadav from comment #0)
> Additional info:
> Ibus emoji should box should remain open if we haven't closed it, so that we
> don't have to open it again if we want to select more than one emoji.

I don't think so.
The dialog works like a lookup table which need to be closed in order to output the selected character into the pre-selected input focus.
If the dialog is not closed, the character cannot be output into the input focus.

What is the problem of you when you need to type Ctrl-Shift-e again?

Comment 2 Pooja Yadav 2018-04-11 05:22:48 UTC
(In reply to fujiwara from comment #1)
> (In reply to Pooja Yadav from comment #0)
> > Additional info:
> > Ibus emoji should box should remain open if we haven't closed it, so that we
> > don't have to open it again if we want to select more than one emoji.
> 
> I don't think so.
> The dialog works like a lookup table which need to be closed in order to
> output the selected character into the pre-selected input focus.
> If the dialog is not closed, the character cannot be output into the input
> focus.
> 
> What is the problem of you when you need to type Ctrl-Shift-e again?

If it is expected that the dialog closes after selection of one emoji, then its okay but in this case we can't input more than one character(emoji) as it is automatically closed. 

There is no problem in opening the dialog again,I just had a thought if it can remain open until we manually close it.

Comment 3 fujiwara 2018-04-11 09:35:19 UTC
Created attachment 1420238 [details]
Engine's lookup table

(In reply to Pooja Yadav from comment #2)
> If it is expected that the dialog closes after selection of one emoji, then
> its okay but in this case we can't input more than one character(emoji) as
> it is automatically closed. 

OK, interesting idea to type multiple emoji.
The emoji typing checks the complete match only by default.

The attaching image is the lookup table in an Japanese engine.

One idea to implement your request would be having a separator likes ';'.
E.g. "smile;cat"

> 
> There is no problem in opening the dialog again,I just had a thought if it
> can remain open until we manually close it.

However I'd think the dialog should be closed one whole the sequence is selected so I'd like to change the bug title later.

Comment 4 fujiwara 2018-07-19 03:10:48 UTC
I'd ask if you need this request for the new UI.
You can check ibus rawhide or f28 copr.

https://copr.fedorainfracloud.org/coprs/fujiwara/ibus/

I think this request is no longer needed since the preedit is moved from the emoji dialog to the preedit.

Comment 5 Pooja Yadav 2018-07-19 11:30:30 UTC
Yeah, we can close this request.


Note You need to log in before you can comment on or make changes to this bug.