Bug 1565523 - engine-backup(8) man page is not up-to-date with engine-backup features
Summary: engine-backup(8) man page is not up-to-date with engine-backup features
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Backup-Restore.Engine
Version: 4.2.2.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ovirt-4.2.4
: ---
Assignee: Asaf Rachmani
QA Contact: Pavel Novotny
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 08:24 UTC by Jiri Belka
Modified: 2018-06-26 08:43 UTC (History)
4 users (show)

Fixed In Version: ovirt-engine-4.2.4.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:43:07 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+
ylavi: exception+
pnovotny: testing_plan_complete-
lsvaty: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90569 0 master MERGED Docs: Updated man page for engine-backup 2018-05-28 11:23:38 UTC
oVirt gerrit 91680 0 ovirt-engine-4.2 MERGED Docs: Updated man page for engine-backup 2018-05-28 12:11:46 UTC

Description Jiri Belka 2018-04-10 08:24:03 UTC
Description of problem:

descr inline:

# man -P cat engine-backup | col -b | sed -n '/^MODES/,/^$/p'
MODES
       backup    backup system into FILE
       restore   restore system from FILE

       ^^^^^^^ missing verify

# man -P cat engine-backup | col -b | sed -n '/^SCOPE/,/^$/p'
SCOPES
       all       complete backup/restore (default)
       db        database only

       ^^ missing other scopes

# engine-backup --help | head
engine-backup: back up and restore ovirt-engine environment
USAGE:
    /usr/bin/engine-backup --mode=MODE --scope=SCOPE --file=FILE --log=FILE [options]
 MODE is one of the following:
    backup                          back up system into FILE
    restore                         restore system from FILE
    verify                          verify FILE

    ^^^^^^ not part of manpage

 SCOPE is one of the following:
    all                             If MODE=backup: backup everything below.
                                    If MODE=restore: restore everything found in FILE.

plus others like archive-compressor, file-compressor, keep-temporary-data

man pages are not dead yet.

Version-Release number of selected component (if applicable):
100 %

How reproducible:
ovirt-engine-tools-backup-4.2.2.6-0.1.el7.noarch

Steps to Reproduce:
1. compare engine-backup --help with engine-backup(8)
2.
3.

Actual results:
man page was not updated to latest tool's features

Expected results:
should be sync, ideally --help should be minimal and people should be taught to read man page (oh, so 90ies)

Additional info:

Comment 1 Pavel Novotny 2018-06-07 15:04:39 UTC
Verified in ovirt-engine-tools-backup-4.2.4.1-0.1.el7.noarch

The man page is now synced with the engine-backup --help instructions,
i.e., the modes, scopes, and command line options are up-to-date.

Excerpt from the current man page:
~~~
# engine-backup --help | head -n 20
engine-backup: back up and restore ovirt-engine environment
USAGE:
    /usr/bin/engine-backup --mode=MODE --scope=SCOPE --file=FILE --log=FILE [options]
 MODE is one of the following:
    backup                          back up system into FILE
    restore                         restore system from FILE
    verify                          verify FILE
 SCOPE is one of the following:
    all                             If MODE=backup: backup everything below.
                                    If MODE=restore: restore everything found in FILE.
    files                           product files only
    db                              Engine database only
    dwhdb                           Data Warehouse database only
    The option --scope can be passed more than once, with different scopes.
 --file=FILE                        file to use during backup or restore
 --log=FILE                         log file to use during backup or restore
 --tmpdir=DIR                       Set temporary directory parent. See also mktemp(1).
                                    Defaults to $TMPDIR, if set, otherwise to /tmp.
 --archive-compressor=COMPRESSOR
    Use COMPRESSOR to compress the backup file, can be one of:
~~~

Comment 2 Sandro Bonazzola 2018-06-26 08:43:07 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.