Bug 1565530 - Sidebar view home page missing icons
Summary: Sidebar view home page missing icons
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-systemsettings
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 08:48 UTC by Ivo C
Modified: 2018-05-22 15:44 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-22 15:44:21 UTC
Type: Bug


Attachments (Terms of Use)
manifestation (85.09 KB, image/png)
2018-04-10 08:48 UTC, Ivo C
no flags Details

Description Ivo C 2018-04-10 08:48:50 UTC
Created attachment 1419770 [details]
manifestation

Description of problem:
When the view style of System Settings is set to sidebar view (default setting), the starting/home page that opens on first start is displayed incorrectly. The icons are black and grey shapes.

Version-Release number of selected component (if applicable):
5.12.4

How reproducible:
Open System Settings in sidebar view

Additional info:
This is on a fully updated (from default repos) Fedora 27 system with Intel integrated graphics on a Celeron 1000M. Enabling or disabling the compositor has no effect, and neither does switching the OpenGL version for the rendering backend. The bug doesn't occur on other distributions with the same Plasma version from cursory live media testing.

Comment 1 Ivo C 2018-04-10 11:34:08 UTC
This can be replicated in a VirtualBox VM. Install Fedora 27 KDE, execute "dnf update", restart and log in, open System Settings.

Comment 2 Benjamin Xiao 2018-04-25 19:32:32 UTC
I've noticed this ever since the KDE Frameworks 5.44 update.

Comment 3 Thomas Carmichael 2018-05-21 23:29:27 UTC
Upstream bug report: https://bugs.kde.org/show_bug.cgi?id=393044

I also had this issue, but with the recent KDE Frameworks 5.46 update in Fedora 28 the issue appears to have been resolved.

Comment 4 Rex Dieter 2018-05-22 15:44:21 UTC
Thanks, marking fixed


Note You need to log in before you can comment on or make changes to this bug.