Bug 1565544 - chronyd doesn't wait for late HW timestamps
Summary: chronyd doesn't wait for late HW timestamps
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: chrony
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Miroslav Lichvar
QA Contact: Ondrej Mejzlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 09:24 UTC by Miroslav Lichvar
Modified: 2019-08-06 12:41 UTC (History)
2 users (show)

Fixed In Version: chrony-3.4-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 12:41:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2076 0 None None None 2019-08-06 12:41:39 UTC

Description Miroslav Lichvar 2018-04-10 09:24:57 UTC
Description of problem:
When chronyd operating as an NTP client with enabled hardware timestamping receives a response from a fast and close server (e.g. an appliance with a hardware-based NTP implementation) before the hardware transmit timestamp of the request, the timestamp is not included in the calculation of the offset. If the server is so fast and close that a large number of measurements is missing the hardware timestamp, the accuracy of the system clock will degrade significantly.

The fix is to rework the NTP I/O code to wait a bit for late HW transmit timestamps before processing the fast response.

A related issue is that enabling kernel receive timestamping has a delay and it may not be enabled in time to timestamp the fast response. If the hardware receive timestamp was missing for any reason, chronyd would have to use the daemon receive timestamp, which may be very inaccurate due to the fix for the previous issue. The fix is to permanently enable the kernel receive timestamping.

Upstream commits:
https://git.tuxfamily.org/chrony/chrony.git/commit/?id=b1647dbcb757dbebb918d397e165808f0901b59d
https://git.tuxfamily.org/chrony/chrony.git/commit/?id=0df8328ceb8af68207b4cdfac8fe938fa87bfb2f
https://git.tuxfamily.org/chrony/chrony.git/commit/?id=8b1f68b1b4044a941d4f2ffc579aea1430ce432c

Version-Release number of selected component (if applicable):
chrony-3.2-2.el7

How reproducible:
Requires special hardware

Steps to Reproduce:
1. configure chronyd with:
      server $HW_NTP_SERVER minpoll 0 maxpoll 0
      hwtimestamp * rxfilter none
      log measurements
   where $HW_NTP_SERVER is a close HW-based NTP server (peer delay + response
   time should be smaller than few tens of microseconds)
2. observe the last two columns in the measurements log

Actual results:
Some measurements (other than the first few) have kernel-kernel (K K), kernel-daemon (K D), or hardware-daemon (H D) timestamps.

Expected results:
All measurements except the first few have hardware-kernel (H K) timestamps.

Additional info:

Comment 7 errata-xmlrpc 2019-08-06 12:41:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2076


Note You need to log in before you can comment on or make changes to this bug.