Bug 1565562 - Sizing requirements for /opt/puppetlabs
Summary: Sizing requirements for /opt/puppetlabs
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Docs Install Guide
Version: 6.3.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: Unspecified
Assignee: Sergei Petrosian
QA Contact: Melanie Corr
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 10:09 UTC by Simon Reber
Modified: 2019-09-26 14:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-30 13:31:21 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Simon Reber 2018-04-10 10:09:36 UTC
Description of problem:

In https://access.redhat.com/documentation/en-us/red_hat_satellite/6.3/html/installation_guide/preparing_your_environment_for_installation#hardware_storage_prerequisites storage requirements for specific directories are documented.

With Red Hat Satellite 6.3 `/opt/puppetlabs` is a newly added directory on Red Hat Satellite 6.3 and once the customer is start using `puppet4` the same will be created on the clients as well.

It's therefore required to properly document the storage requirements for `/opt/puppetlabs` to make sure it's put into consideration when upgrading from Red Hat Satellite 6.2 to 6.3.

Also for the clients there should be a note, that the directory will be created once `puppet4` is rolled out, providing information of how much space is required.

Engineering is considering the sizing as following: "Master might have
reports as files which could take up some space but I'd guess at most
in the 100s of MBs."

Version-Release number of selected component (if applicable):

 - satellite-6.3.0.1-1.el7sat.noarch

How reproducible:

 - Always

Steps to Reproduce:
1. Check https://access.redhat.com/documentation/en-us/red_hat_satellite/6.3/html/installation_guide/preparing_your_environment_for_installation#hardware_storage_prerequisites

Actual results:

No information about the newly created/required `/opt/puppetlabs`

Expected results:

`/opt/puppetlabs` should be documented and highlighted that it is required for `puppet4` on both Red Hat Satellite 6.3 and the clients and the approx. storage consumption.

Additional info:

Comment 3 Ewoud Kohl van Wijngaarden 2018-04-13 17:29:46 UTC
Hello Sergei,

I haven't done any scale testing of the `/opt/puppetlabs` directory nor am I planning to. My focus of Puppet is mostly as a user and a developer on the installer. It's probably best to reach out to the performance team since they have a lab setup with a proper size.

On my personal puppet master /opt/puppetlabs/ is 230M. This includes about 10MB of state. 7 MB of this is because it's also a client, the other 3 is some caches for the ~10 clients I have. Now I don't manage a lot so it's fairly minimal.

On the client side things that can grow are backups of old files and pluginsync. This used to live in /var/lib/puppet. If you manage huge files and there are a lot of backups or have huge ruby libraries in your types/providers, then it can grow. I'd estimate typical deployments in the 10s of MBs.

On the server side there are yaml files with reports. In my small env those are 200KB.

Since my env is small, this is probably not representative of huge envs with 1000s of servers, but for most customers it will be rather small.

I hope this helps, but do reach out to the performance team.


Note You need to log in before you can comment on or make changes to this bug.