Bug 1565584 - some units in units_rpm missing downloaded column
Summary: some units in units_rpm missing downloaded column
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Pulp
Version: 6.2.14
Hardware: All
OS: All
unspecified
high
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Kersom
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 11:01 UTC by Jan Jansky
Modified: 2019-12-03 12:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-03 12:53:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
script for unassociating, delete_orphan content (3.04 KB, application/x-shellscript)
2018-04-10 11:01 UTC, Jan Jansky
no flags Details

Description Jan Jansky 2018-04-10 11:01:35 UTC
Created attachment 1419837 [details]
script for unassociating, delete_orphan content

Description of problem:
Some units in units_rpm missing the downloaded column value which prevents to download rpm onto filesystem

Version-Release number of selected component (if applicable):
pulp-admin-client-2.8.7.18-1.el7sat.noarch                  Tue Feb  6 10:18:37 2018
pulp-client-1.0-1.noarch                                    Thu Aug 17 15:23:38 2017
pulp-docker-plugins-2.0.3.1-1.el7sat.noarch                 Thu Aug 17 13:27:17 2017
pulp-katello-1.0.2-1.el7sat.noarch                          Thu Aug 17 13:27:17 2017
pulp-puppet-plugins-2.8.7.2-1.el7sat.noarch                 Tue Feb  6 10:19:32 2018
pulp-puppet-tools-2.8.7.2-1.el7sat.noarch                   Tue Feb  6 10:18:37 2018
pulp-rpm-admin-extensions-2.8.7.18-1.el7sat.noarch          Tue Feb  6 10:20:36 2018
pulp-rpm-handlers-2.8.7.18-1.el7sat.noarch                  Tue Feb  6 10:20:35 2018
pulp-rpm-plugins-2.8.7.18-1.el7sat.noarch                   Tue Feb  6 10:19:32 2018
pulp-selinux-2.8.7.18-1.el7sat.noarch                       Tue Feb  6 10:19:42 2018
pulp-server-2.8.7.18-1.el7sat.noarch                        Tue Feb  6 10:19:31 2018


How reproducible:
cannot reproduce, customer specific problem

Actual results:
echo "DBQuery.shellBatchSize = 10000000" > .mongorc.js ; mongo pulp_database --eval "load('.mongorc.js'); db.units_rpm.find({filename: 'python2-pyasn1-0.1.9-7.el7.noarch.rpm'},{filename: true, downloaded:true}).shellPrint()"
{ "_id" : "02256ddc-53d0-4b4b-babf-302174e71a6b", "filename" : "python2-pyasn1-0.1.9-7.el7.noarch.rpm", "downloaded" : true }
{ "_id" : "d72a71b8-c625-4915-9bd5-fa43ac0edb7b", "filename" : "python2-pyasn1-0.1.9-7.el7.noarch.rpm" }

Expected results:
echo "DBQuery.shellBatchSize = 10000000" > .mongorc.js ; mongo pulp_database --eval "load('.mongorc.js'); db.units_rpm.find({filename: 'python2-pyasn1-0.1.9-7.el7.noarch.rpm'},{filename: true, downloaded:true}).shellPrint()"
{ "_id" : "02256ddc-53d0-4b4b-babf-302174e71a6b", "filename" : "python2-pyasn1-0.1.9-7.el7.noarch.rpm", "downloaded" : true }
{ "_id" : "d72a71b8-c625-4915-9bd5-fa43ac0edb7b", "filename" : "python2-pyasn1-0.1.9-7.el7.noarch.rpm", "downloaded" : true }

Additional info:
I wrote script to find those units, unassociate them from repositories, delete_orphaned content and sync repositories again, but now they are even more records without downloaded column.



I am uploading the script

Comment 3 Jan Jansky 2018-04-11 11:26:08 UTC
Requested query:

{ "_id" : "02256ddc-53d0-4b4b-babf-302174e71a6b",  "_storage_path" : "/var/lib/pulp/content/rpm/python2-pyasn1/0.1.9/7.el7/noarch/f552ce87fa13d4e85cb7e2fb4861aa82e907c1b0/python2-pyasn1-0.1.9-7.el7.noarch.rpm" }
{ "_id" : "d72a71b8-c625-4915-9bd5-fa43ac0edb7b", "_storage_path" : "/var/lib/pulp/content/rpm/python2-pyasn1/0.1.9/7.el7/noarch/317907ab20c6f072f8d0e32d981de70c58b69e61136075beffa7dc27fbcb7804/python2-pyasn1-0.1.9-7.el7.noarch.rpm" }
{ "_id" : "9000cd2d-ebc4-470c-86aa-7d39471b8087", "_storage_path" : "/var/lib/pulp/content/rpm/python2-pyasn1/0.1.9/7.el7/noarch/3b14cb5167b2dc1d2b999e87a9f376f60e81faa4552c36293b770b277d432881/python2-pyasn1-0.1.9-7.el7.noarch.rpm" }

Not even one record have downloaded value

Comment 4 Jan Jansky 2018-10-18 10:21:12 UTC
Hello,
any progress on this? Bug is opened from April and customer still have same issue.

We need development help with migration of mongodb table units_rpm to achieve that all rpm inside will have value downloaded.

Best Regards
Jan Jansky

Comment 5 David Davis 2018-10-18 12:26:29 UTC
The downloaded field should be set to true as the last step of a successful sync. Since downloaded is not set, it leads me to believe that these rpms are failing to sync. Are there any errors or log information from these syncs?

Comment 6 Bryan Kearney 2019-11-04 14:33:59 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 7 Bryan Kearney 2019-12-03 12:53:30 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.