Bug 1565594 - Warning messages in satellite 6.3: Puppet Support for ruby version 1.9.3 is deprecated and will be removed in a future release.
Summary: Warning messages in satellite 6.3: Puppet Support for ruby version 1.9.3 is ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Puppet
Version: 6.3.0
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Peter Ondrejka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 11:30 UTC by Diksha Chaudhari
Modified: 2019-12-03 12:53 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-03 12:53:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3412281 None None None 2018-05-16 05:55:06 UTC

Description Diksha Chaudhari 2018-04-10 11:30:19 UTC
Description of problem: When the satellite is upgraded from 6.1 → 6.2 → 6.3, the puppet package version upgrades to 4.11.3 while there seems to be warning messages in satellite 6.3: Puppet Support for ruby version 1.9.3 is deprecated and will be removed in a future release.

Version-Release number of selected component (if applicable): Satellite 6.3 and Puppet package version 4.11.3

How reproducible: Always

Steps to Reproduce:

1) Upgrade satellite
Upgrade the satellite from 6.1 → 6.2 → 6.3

2)  Upgrade puppet 4
      
3) Check for the deprecation warning in /var/log/puppetlabs/puppetserver.log:
2018-04-09 10:06:13,402 WARN  [clojure-agent-send-pool-0] [puppetserver] Puppet Support for ruby version 1.9.3 is deprecated and will be removed in a future release. See https://docs.puppet.com/puppet/latest/system_requirements.html#ruby for a list of supported ruby versions. (at /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet.rb:180:in `Puppet')

Actual results: Deprecation warning in puppetserver.log is observed even after removing the ruby193-ruby.x86_64 packages. 

Expected results: Deprecation warning messages should not be reflected in the logs.

Additional info: 

1) Found many ruby193 packages on the upgraded satellite 6.3.
2) Removed the ruby193 packages and checked again for the deprecation warnings in puppetserver.log 
# yum remove ruby193-ruby.x86_64

Still, the issue persists.

Also, these warning messages do not occur in the freshly installed satellite 6.3.

Comment 3 Bryan Kearney 2019-11-04 14:33:52 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 4 Bryan Kearney 2019-12-03 12:53:18 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.