Bug 1565627 - VM brq-openstack is down with error. Exit message: XML error: both maximum memory size and memory slot count must be specified.
Summary: VM brq-openstack is down with error. Exit message: XML error: both maximum me...
Keywords:
Status: CLOSED DUPLICATE of bug 1557272
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core
Version: 4.2.2.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Nobody
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 12:56 UTC by Jiri Belka
Modified: 2018-04-16 13:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-16 13:00:37 UTC
oVirt Team: Virt


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1557272 0 unspecified CLOSED If VMs are paused while cluster compatiblity level is upgraded, they may receive 0 as maxmemory and fail to start 2021-02-22 00:41:40 UTC

Internal Links: 1557272

Description Jiri Belka 2018-04-10 12:56:25 UTC
Description of problem:

the vm was started on 4.1 cluster and cannot be started on 4.2 because of:


it seems there's odd max memory:

-[ RECORD 1 ]------------------+----------------------------------------------------------------------------------------
vm_name                        | brq-openstack
mem_size_mb                    | 2048
max_memory_size_mb             | 4194304

(also visible in admin portal)

changing max memory in admin portal solved the issue:

-[ RECORD 1 ]------------------+----------------------------------------------------------------------------------------
vm_name                        | brq-openstack
mem_size_mb                    | 2048
max_memory_size_mb             | 16384



Version-Release number of selected component (if applicable):
ovirt-engine-4.2.2.6-0.1.el7.noarch

How reproducible:
1 in 1

Steps to Reproduce:
1. 
2.
3.

Actual results:
a vm which got started in time of 4.1 cluster cannot run on 4.2 env now

Expected results:
should work

Additional info:

Comment 2 Yaniv Kaul 2018-04-11 06:34:00 UTC
Dup of https://bugzilla.redhat.com/show_bug.cgi?id=1557272 ?

Comment 3 Jiri Belka 2018-04-11 06:46:17 UTC
(In reply to Yaniv Kaul from comment #2)
> Dup of https://bugzilla.redhat.com/show_bug.cgi?id=1557272 ?

Seems so, so after one month we still have the issue here.

Comment 4 Michal Skrivanek 2018-04-16 13:00:37 UTC

*** This bug has been marked as a duplicate of bug 1557272 ***


Note You need to log in before you can comment on or make changes to this bug.