Bug 1565632 - nftables version bump (0.7 is too old)
Summary: nftables version bump (0.7 is too old)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nftables
Version: 27
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 12:59 UTC by Ian Kumlien
Modified: 2018-04-27 01:17 UTC (History)
3 users (show)

Fixed In Version: nftables-0.8.3-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-27 01:17:30 UTC


Attachments (Terms of Use)

Description Ian Kumlien 2018-04-10 12:59:03 UTC
Description of problem:
The shipped version of nftables in fedora is too old, and it causes a lot of problems.

(The parser is fickly and much better in later versions)

Version-Release number of selected component (if applicable):
0.7

How reproducible:
use a variable in a variable f.ex. or any number of things that has been fixed since this release

Steps to Reproduce:
1.
2.
3.

Actual results:
Crash, coredump

Expected results:
New shiny firewall in place

Additional info:
The current version of nftables is form 20/December 2016 - while the latest release is from 3/March 2018

I think that this is something that should be bumped often... By comparison iptables is from 27/January 2017 (and there is a bug report to bump it to 1.6.2)

Comment 1 Kevin Fenzi 2018-04-15 17:37:38 UTC
This was pushed as part of an update to iptables:

https://bodhi.fedoraproject.org/updates/FEDORA-2018-1c31f1eccd

But there were problems with iptables. I asked if these could be split off that and pushed sooner.

Comment 2 Fedora Update System 2018-04-15 19:11:13 UTC
libnftnl-1.0.9-2.fc27 nftables-0.8.3-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-6579155997

Comment 3 Fedora Update System 2018-04-15 20:09:38 UTC
libnftnl-1.0.9-2.fc27 nftables-0.8.3-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-6579155997

Comment 4 Fedora Update System 2018-04-18 02:58:17 UTC
libnftnl-1.0.9-2.fc27, nftables-0.8.3-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-6579155997

Comment 5 Fedora Update System 2018-04-27 01:17:30 UTC
libnftnl-1.0.9-2.fc27, nftables-0.8.3-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.