Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1565648 - expose _apb_service_binding_id to bind role
Summary: expose _apb_service_binding_id to bind role
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: unspecified
Hardware: All
OS: All
low
unspecified
Target Milestone: ---
: 3.11.0
Assignee: Jesus M. Rodriguez
QA Contact: Zhang Cheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 13:21 UTC by Peter Braun
Modified: 2018-12-21 15:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-21 15:16:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github 866 0 None None None 2018-04-10 13:21:30 UTC

Description Peter Braun 2018-04-10 13:21:30 UTC
Description of problem:


Currently the provision role has access to the ID of the service instance (_apb_service_instance_id). This is useful in cases where we need to label the service instance and make it discoverable.

Something similar would be useful for the bind role. Bind creates a serviceBinding instance with a non-deterministic name. In order to trigger unbind one has to delete this service binding object. This can be done via the UI.

But suppose you want to trigger unbind externally. There is currently no way to know which service binding to delete.


How reproducible:

always

Steps to Reproduce:
1. Run a bind action and view the parameters passed to ansible
2. _apb_service_instance_id is present, but _apb_service_binding_id not


Expected results:

_apb_service_binding_id should also be present.

Comment 1 Jesus M. Rodriguez 2018-08-03 23:46:39 UTC
Fixed by PR https://github.com/openshift/ansible-service-broker/pull/883

available in broker version 1.2.6-1 or later

Comment 2 Zhang Cheng 2018-08-10 09:12:25 UTC
Moving status to Verified since this issue already been fixed.

For example:

{
  "_apb_last_requesting_user": "chezhang",
  "_apb_plan_id": "dev",
  "_apb_provision_creds": {
    "API_KEY": "KAYKxAgFtuCRk2D9H24W",
    "API_SECRET": "b0R8s7X9t1sCZGYZHzAU",
    "API_URL": "http://demo-api"
  },
  "_apb_service_binding_id": "48d4e2b1-9c7c-11e8-bfdb-0a580a800006",
  "_apb_service_class_id": "21e1bfbf09d5a7fb8a54042f504f26be",
  "_apb_service_instance_id": "a5c96f69-9c7b-11e8-bfdb-0a580a800006",
  "cluster": "openshift",
  "namespace": "test4"
}

Comment 3 Luke Meyer 2018-12-21 15:16:42 UTC
Closing bugs that were verified and targeted for GA but for some reason were not picked up by errata. This bug fix should be present in current 3.11 release content.


Note You need to log in before you can comment on or make changes to this bug.