Bug 1565649 - ndctl list stuck because nvdimm driver is busy performing ARS (address-range-scrub)
Summary: ndctl list stuck because nvdimm driver is busy performing ARS (address-range-...
Keywords:
Status: CLOSED DUPLICATE of bug 1539278
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ndctl
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Jeff Moyer
QA Contact: Storage QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 13:21 UTC by Yigal Korman
Modified: 2018-04-17 13:22 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-17 13:22:32 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yigal Korman 2018-04-10 13:21:32 UTC
Description of problem:

After booting a fresh system with NVDIMM devices, trying to run 'ndctl list -N' will hang.
No pmem devices will appear in the system ('lsblk' doesn't list them).

This was investigated and found related to address-range-scrub process performed by the NVDIMM/NFIT kernel driver. The process takes a long time (usually times out after 90 seconds for each NVDIMM, may take more that 20 minutes for a large amount of devices) and during it, NVDIMM driver and devices are not accessible.

Version-Release number of selected component (if applicable):
ndctl version 56
kernel version 3.10.0-693

How reproducible:
Boot system with NVDIMMs
Login to prompt
Run 'ndctl list -N'

Actual results:
The command will be stuck.


Expected results:
The command should return "busy" or a list of nvdimm devices.


Additional info:
There are linux kernel patches proposed here:
https://www.spinics.net/lists/linux-acpi/msg81584.html
That should mitigate this issue.

Comment 2 Jeff Moyer 2018-04-17 13:22:32 UTC

*** This bug has been marked as a duplicate of bug 1539278 ***


Note You need to log in before you can comment on or make changes to this bug.