Bug 1565652 - [tripleo]: Automated UI testing in CI
Summary: [tripleo]: Automated UI testing in CI
Keywords:
Status: CLOSED DUPLICATE of bug 1545275
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Honza Pokorny
QA Contact: Arik Chernetsky
URL: https://blueprints.launchpad.net/trip...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 13:28 UTC by Beth White
Modified: 2018-08-07 10:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-07 10:01:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 546817 0 None None None 2018-04-10 13:28:36 UTC

Description Beth White 2018-04-10 13:28:33 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/tripleo/+spec/automated-ui-testing.

Description:

At the moment, upstream CI only tests for lint errors, and runs our unittests. We'd like to add more integration tests for tripleo-ui to the CI pipeline. This will include a selenium-based approach. This allows us to simulate a browser by using a headless browser when running in CI, and we can detect a lot more problems than we ever could with just unittesting.

This new work should be integrated into the upcoming tempest plugin for tripleo-ui for ease of reporting

Specification URL (additional information):

None

Comment 1 Honza Pokorny 2018-08-07 10:01:21 UTC

*** This bug has been marked as a duplicate of bug 1545275 ***


Note You need to log in before you can comment on or make changes to this bug.