Bug 1565674 (CVE-2018-9256) - CVE-2018-9256 wireshark: stack overflow via crafted LWAPP Layer 3 Packet
Summary: CVE-2018-9256 wireshark: stack overflow via crafted LWAPP Layer 3 Packet
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2018-9256
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1565675 1565676 1565684 1575726
Blocks: 1565716
TreeView+ depends on / blocked
 
Reported: 2018-04-10 14:16 UTC by Laura Pardo
Modified: 2019-09-29 14:35 UTC (History)
7 users (show)

Fixed In Version: wireshark 2.4.6, wireshark 2.2.14
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-07 18:42:17 UTC


Attachments (Terms of Use)

Description Laura Pardo 2018-04-10 14:16:50 UTC
A flaw was found in Wireshark 2.4.0 to 2.4.5 and 2.2.0 to 2.2.13, the LWAPP dissector could crash. This was addressed in epan/dissectors/packet-lwapp.c by limiting the encapsulation levels to restrict the recursion depth.


References:
https://www.wireshark.org/security/wnpa-sec-2018-20.html
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=14467

Patch:
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=dac48f148538c706c446e5105d84ebcb54587528

Comment 1 Laura Pardo 2018-04-10 14:18:23 UTC
Created wireshark tracking bugs for this issue:

Affects: fedora-26 [bug 1565676]

Comment 3 Laura Pardo 2018-04-10 15:37:02 UTC
Created wireshark tracking bugs for this issue:

Affects: fedora-all [bug 1565684]


Note You need to log in before you can comment on or make changes to this bug.