Bug 1565730 - State field may be missing from virsh output
Summary: State field may be missing from virsh output
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: 2.2.16
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.2.3
: ---
Assignee: Denis Chaplygin
QA Contact: Nikolai Sednev
URL:
Whiteboard:
: 1567794 (view as bug list)
Depends On:
Blocks: 1458709
TreeView+ depends on / blocked
 
Reported: 2018-04-10 15:47 UTC by Denis Chaplygin
Modified: 2018-05-10 06:33 UTC (History)
6 users (show)

Fixed In Version: ovirt-hosted-engine-setup-2.2.19-1.el7ev
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 06:33:16 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+
ylavi: exception+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90170 0 master MERGED ansible: virsh dom-info replaced with virsh domstate 2018-09-03 09:33:37 UTC
oVirt gerrit 90406 0 ovirt-hosted-engine-setup-2.2 MERGED ansible: virsh dom-info replaced with virsh domstate 2018-04-20 16:11:57 UTC

Internal Links: 1569372

Description Denis Chaplygin 2018-04-10 15:47:35 UTC
Description of problem: At create_target_vm.yml we grep virsh output for State feidl, but it may be missing.


Version-Release number of selected component (if applicable): master


How reproducible: rarely


Steps to Reproduce:
1. Install HE using ansible flow

Actual results: May fail with 
[ INFO ] TASK [Wait for local VM shutdown]
<dchaplyg> [ ERROR ] fatal: [localhost]: FAILED! => {"attempts": 120, "changed": true, "cmd": "virsh -r dominfo \"HostedEngineLocal\" | grep State", "delta": "0:00:00.069798", "end": "2018-04-10 17:41:35.605540", "msg": "non-zero return code", "rc": 1, "start": "2018-04-10 17:41:35.535742", "stderr": "", "stderr_lines": [], "stdout": "", "stdout_lines": []}
<dchaplyg> tiraboschi, is it a new issue or well known?


Expected results: Should not fail


Additional info: we could use virsh domstate instead

Comment 1 Yaniv Kaul 2018-04-11 06:34:21 UTC
Severity?

Comment 2 Simone Tiraboschi 2018-04-20 15:55:52 UTC
*** Bug 1567794 has been marked as a duplicate of this bug. ***

Comment 3 Simone Tiraboschi 2018-04-20 15:59:13 UTC
Got another report, re-targeting it.

Comment 4 Nikolai Sednev 2018-05-01 12:44:46 UTC
Works for me on these components:
ovirt-engine-4.2.3.3-0.1.el7.noarch
rhvm-appliance-4.2-20180427.0.el7.noarch
ovirt-hosted-engine-setup-2.2.19-1.el7ev.noarch
ovirt-hosted-engine-ha-2.2.11-1.el7ev.noarch
Linux 3.10.0-862.el7.x86_64 #1 SMP Wed Mar 21 18:14:51 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.5 (Maipo)

Please reopen if you still see this issue.

Comment 5 Sandro Bonazzola 2018-05-10 06:33:16 UTC
This bugzilla is included in oVirt 4.2.3 release, published on May 4th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.