Bug 1565742 (CVE-2018-9261) - CVE-2018-9261 wireshark: NBAP dissector crash in epan/dissectors/packet-nbap.c
Summary: CVE-2018-9261 wireshark: NBAP dissector crash in epan/dissectors/packet-nbap.c
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2018-9261
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1565675 1565684 1575730
Blocks: 1565716
TreeView+ depends on / blocked
 
Reported: 2018-04-10 16:15 UTC by Laura Pardo
Modified: 2019-09-29 14:37 UTC (History)
7 users (show)

Fixed In Version: wireshark 2.4.6, wireshark 2.2.14
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-07 18:44:44 UTC


Attachments (Terms of Use)

Description Laura Pardo 2018-04-10 16:15:56 UTC
A flaw was found in Wireshark 2.4.0 to 2.4.5 and 2.2.0 to 2.2.13, the NBAP dissector could crash with a large loop that ends with a heap-based buffer overflow. This was addressed in epan/dissectors/packet-nbap.c by prohibiting the self-linking of DCH-IDs.


References:
https://www.wireshark.org/security/wnpa-sec-2018-18.html
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=14471

Patch:
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=66bc372716e04d6a8afdf6712583c9b5d11fee55

Comment 1 Laura Pardo 2018-04-10 16:17:16 UTC
Created wireshark tracking bugs for this issue:

Affects: fedora-all [bug 1565684]


Note You need to log in before you can comment on or make changes to this bug.