Bug 1565775 - rebase elfutils in RHEL 7.6
Summary: rebase elfutils in RHEL 7.6
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: elfutils   
(Show other bugs)
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Mark Wielaard
QA Contact: Martin Cermak
Vladimír Slávik
URL:
Whiteboard:
Keywords: Rebase
Depends On:
Blocks: 1505884
TreeView+ depends on / blocked
 
Reported: 2018-04-10 18:25 UTC by David Smith
Modified: 2018-11-07 14:44 UTC (History)
4 users (show)

Fixed In Version: elfutils-0.172-1.el7
Doc Type: Rebase: Enhancements Only
Doc Text:
_elfutils_ rebased to version 0.172 The _elfutils_ packages have been upgraded to upstream version 0.172. This update adds support for the DWARF5 debug information format, split-dwarf, and GNU DebugFission: * The `eu-readelf` tool can display split unit DIEs when the `--debug-dump=info+` option is used. * The `eu-readelf` tool can inspect separate `.dwo` DWARF "skeleton files" with debug information when the `--dwarf-skeleton` option is used. * The *libdw* library now tries to resolve the "alt file" containing linked debug information even when it has not yet been set with the `dwarf_set_alt()` function. * The *libdw* library has been extended with the functions `dwarf_die_addr_die()`, `dwarf_get_units()`, `dwarf_getabbrevattr_data()` and `dwarf_cu_info()`.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-10-30 10:35:29 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3149 None None None 2018-10-30 10:35 UTC

Description David Smith 2018-04-10 18:25:58 UTC
We plan to incorporate soon to be released upstream elfutils into RHEL 7.6.

Comment 4 Mark Wielaard 2018-06-12 06:19:23 UTC
We are going with 0.172, which has not functional changes over 0.171, but lots of bug fixes for handling bad DWARF5 data.

Comment 11 errata-xmlrpc 2018-10-30 10:35:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3149


Note You need to log in before you can comment on or make changes to this bug.