Bug 1565790 - [apb-base] Ansible in apb-base image should not create retry files
Summary: [apb-base] Ansible in apb-base image should not create retry files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.10.0
Assignee: Michael Hrivnak
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 19:31 UTC by David Zager
Modified: 2018-07-30 19:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:12:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:13:02 UTC

Description David Zager 2018-04-10 19:31:51 UTC
Description of problem:

Typically, when using ansible, retry files are very helpful for...retrying. However, in the containerized Ansible case there is no need to create these.

Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. docker run --entrypoint /bin/bash docker.io/ansibleplaybookbundle/apb-base:latest
2. cat /etc/ansible/ansible.cfg

Expected results:

The file should include "retry_files_enabled = False"

Comment 2 Jian Zhang 2018-04-26 07:04:14 UTC
Verify succeed. Details as below:

[root@host-172-16-120-36 ~]# docker inspect docker.io/ansibleplaybookbundle/apb-base --format "{{ index .Created}}"
2018-04-25T16:19:52.420021535Z

[root@host-172-16-120-36 ~]# docker run -ti --entrypoint /bin/bash docker.io/ansibleplaybookbundle/apb-base:latest
bash-4.2# ls
ansible.cfg  etc  hosts
bash-4.2# cat ansible.cfg 
[defaults]
retry_files_enabled = False
inventory = /opt/apb/hosts
roles_path = /etc/ansible/roles:/opt/ansible/roles

Comment 4 errata-xmlrpc 2018-07-30 19:12:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.