Bug 1565830 - Remote execution will fail with Net::SSH::ConnectionTimeout if the global ssh client ConnectTimeout setting is set to 0
Summary: Remote execution will fail with Net::SSH::ConnectionTimeout if the global ssh...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Remote Execution
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Peter Ondrejka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 21:00 UTC by Pablo Hess
Modified: 2019-12-03 12:53 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-03 12:53:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3407381 0 None None None 2019-10-15 09:40:26 UTC

Description Pablo Hess 2018-04-10 21:00:04 UTC
Description of problem:
When OpenSSH's client settings specify ConnectTimeout as 0 (zero), net/ssh will immediately timeout when attempting an SSH connection. In contrast, openssh-client (the ssh command) will complete successfully using the exact same client config file.

This is preventing Satellite 6.3.0 from running remote execution jobs if "ConnectTimeout 0" is set in either ~foreman-proxy/.ssh/config or /etc/ssh/ssh_config.


Version-Release number of selected component (if applicable):
tfm-rubygem-net-ssh-4.0.1-2.el7sat.noarch


How reproducible:
Every time.

Steps to Reproduce:
1. Add this content to /etc/ssh/ssh_config on a Satellite 6.3:
Host *
  ConnectTimeout 0
2. Attempt to run any remote execution job.


Actual results:
Fails every time with:
Error initializing command: Net::SSH::ConnectionTimeout -  Net::SSH::ConnectionTimeout
Exit status: EXCEPTION


Expected results:
It should interpret "ConnectTimeout 0" exactly like the openssh client utility does. Apparently openssh client will ignore ConnectTimeout if set to 0.


Additional info:

This issue is new to Satellite 6.3.0.

Changing the @server_version declaration in line 84 of usr/share/gems/gems/net-ssh-4.0.1/lib/net/ssh/transport/session.rb to set any integer instead of relying on options[:timeout] resolved the issue during my tests.

Comment 3 rajasekar 2018-05-07 21:27:25 UTC
is there any update on this bug

Comment 6 rajasekar 2018-09-03 22:41:00 UTC
Hi Team,

Seems this bug is still exits in satellite 6.3.3, let me know thw status.

Comment 10 Bryan Kearney 2019-11-04 14:34:15 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 11 Bryan Kearney 2019-12-03 12:53:49 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.