Bug 1565847 - Xvfb randomly crashes during reset (when mutter as the last client disconnects)
Summary: Xvfb randomly crashes during reset (when mutter as the last client disconnects)
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 29
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2018-04-10 22:28 UTC by Benjamin Berg
Modified: 2019-11-27 19:00 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2019-11-27 19:00:26 UTC
Type: Bug

Attachments (Terms of Use)
Valgrind log of crash (13.37 KB, text/plain)
2018-04-12 19:17 UTC, Benjamin Berg
no flags Details

Description Benjamin Berg 2018-04-10 22:28:00 UTC
Xvfb crashes randomly when if I run only mutter in Xvfb and just abort mutter.

Steps to Reproduce:
1. $ Xvfb :10 &
2. $ XDG_SESSION_TYPE=x11 DISPLAY=:10 mutter
3. Hit Ctrl+C
4. Repeat from 2 if Xvfb did not crash

The result are random crashes (the backtraces also seem random). No crash happens if "-noreset" is passed to Xvfb.

Tested in a mock environment (requires: mesa-dri-drivers, mutter, gnome-settings-dameon, xorg-x11-server-Xvfb and maybe more).

(EE) Backtrace:
(EE) 0: Xvfb (OsLookupColor+0x13d) [0x5641ed]
(EE) 1: /lib64/libpthread.so.0 (funlockfile+0x50) [0x7fb887ee706f]
(EE) 2: Xvfb (ht_dump_contents+0x26fcb) [0x4aaf8b]
(EE) 3: Xvfb (SendErrorToClient+0x35e) [0x50d08e]
(EE) 4: Xvfb (InitFonts+0x3c6) [0x5110d6]
(EE) 5: /lib64/libc.so.6 (__libc_start_main+0xeb) [0x7fb887b391eb]
(EE) 6: Xvfb (_start+0x2a) [0x42606a]

When I ran in gdb, I saw and variants:
(gdb) bt
#0  0x0000000000823070 in ?? ()
#1  0x000000000050d02e in Dispatch ()
#2  0x0000000000511096 in dix_main ()
#3  0x00007ffff57871eb in __libc_start_main () from /lib64/libc.so.6
#4  0x000000000042606a in _start ()

Comment 1 Adam Jackson 2018-04-12 16:21:42 UTC
Having some difficulty reproducing that here. Any chance you can try running Xvfb under valgrind?

Comment 2 Benjamin Berg 2018-04-12 19:17:19 UTC
Created attachment 1421028 [details]
Valgrind log of crash

A good idea to try with valgrind and it actually crashed again.

File contains the valgrind log and stdout/stderr output.

Comment 3 Benjamin Berg 2018-04-12 19:24:37 UTC
Hm, I would redo it with debug symbols included, but I can't seem to find a way to install them right now.

Comment 4 Jan Kurik 2018-08-14 10:07:19 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 5 Ben Cotton 2019-10-31 20:53:54 UTC
This message is a reminder that Fedora 29 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 29 on 2019-11-26.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '29'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 29 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 6 Ben Cotton 2019-11-27 19:00:26 UTC
Fedora 29 changed to end-of-life (EOL) status on 2019-11-26. Fedora 29 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.