This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 156585 - missing 1280x800 resolution in firstboot display config
missing 1280x800 resolution in firstboot display config
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
: Reopened
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2005-05-01 22:29 EDT by Jonathan S. Shapiro
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 17:53:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan S. Shapiro 2005-05-01 22:29:50 EDT
Description of problem:


When configuring a new wxga laptop, the display drop box includes 1280x800mode,
but the resolution dropbox does not. Need to add 1280x800 to the resolution drop
list.

Bug probably exists in x86_64 as well, but have not tested separately.
Comment 1 Mike A. Harris 2005-06-02 17:27:08 EDT
Moving to FC5Target, as FC4 is 'done', barring release blockers that
pop up.
Comment 2 Adam Jackson 2006-04-19 13:14:30 EDT
please attach your Xorg.0.log.
Comment 3 Jonathan S. Shapiro 2006-06-27 14:31:16 EDT
Somebody moved this bug incorrectly. It is NOT a bug in system-config-display.
It is a bug in the kickstart scripting language, and consequently in the
system-config-kickstart utility. It is also a problem in firstboot. Note that
firstboot does not depend in any way on the X11 config. The problem is simply
that no option to select 1280x800 (WXGA) resolution is provided in either tool.
Since this is is now a nearly universal resolution on newer laptops, it seems
like a good idea to add it.

The fix is to add this option to the kickstart file choices and the
system-config-kickstart utility, and (if needed) to firstboot as well.

Please reopen this bug and reassign it to the kickstart team.
Comment 4 Mike A. Harris 2006-07-26 07:05:42 EDT
+# 1280x800 @ 60.00 Hz (GTF) hsync: 49.68 kHz; pclk: 83.46 MHz
+Modeline "1280x800"  83.46  1280 1344 1480 1680  800 801 804 828  -HSync +Vsync
The following modes are present in the rawhide X server:

+# 1280x800 @ 70.00 Hz (GTF) hsync: 58.31 kHz; pclk: 98.89 MHz
+Modeline "1280x800"  98.89  1280 1352 1488 1696  800 801 804 833  -HSync +Vsync
+
+# 1280x800 @ 75.00 Hz (GTF) hsync: 62.62 kHz; pclk: 107.21 MHz
+Modeline "1280x800"  107.21  1280 1360 1496 1712  800 801 804 835  -HSync +Vsync
+
+# 1280x800 @ 85.00 Hz (GTF) hsync: 71.40 kHz; pclk: 123.38 MHz
+Modeline "1280x800"  123.38  1280 1368 1504 1728  800 801 804 840  -HSync +Vsync


(In reply to comment #3)
> Somebody moved this bug incorrectly. It is NOT a bug in system-config-display.
> It is a bug in the kickstart scripting language, and consequently in the
> system-config-kickstart utility.

system-config-display is what configures the X server.  I don't see how
kickstart is relevant.

> It is also a problem in firstboot. Note that
> firstboot does not depend in any way on the X11 config. The problem is simply
> that no option to select 1280x800 (WXGA) resolution is provided in either tool.
> Since this is is now a nearly universal resolution on newer laptops, it seems
> like a good idea to add it.
> 
> The fix is to add this option to the kickstart file choices and the
> system-config-kickstart utility, and (if needed) to firstboot as well.
> 
> Please reopen this bug and reassign it to the kickstart team.

It isn't completely clear to me at least, what exactly it is you are
reporting/requesting here.  I have confirmed that the X server contains
the requested video modes, so they should be visible in system-config-display
as available modes as well, since it shares the extramodes file with the
X server.

Closing bug as being fixed in RAWHIDE, however if you believe that what
you are trying to request is not already present, then please reopen
the bug, reassign it to the component that you believe is lacking the
feature you are asking for, and try to explain exactly what you are
wanting more clearly.

Thanks in advance.
Comment 5 Jonathan S. Shapiro 2006-07-26 10:57:38 EDT
>system-config-display is what configures the X server.  I don't see how
>kickstart is relevant.

Then you didn't read the original bug report carefully enough. This was NEVER a
bug with system-config-display. This is a bug in the initial display
configuration that is accomplished using system-config-kickstart, and also in
the firstboot stuff.

Try this: run system-config-kickstart. Do what you need to do to get to the
place where it wants to configure the initial X resolution. Try to set it to
1280x800. You can't. There is no such choice on the menu. You also cannot do it
by hand, because the kickstart file's "xconfig --resolution" option will not
accept 1280x800 as a legal input.

So, once again: please reassign this to anaconda or system-config-kickstart
(which is where I had it originally), and please actually *read* the bug report
and the subsequent discussion before you jump to conclusions.
Comment 6 Jonathan S. Shapiro 2006-07-26 11:01:34 EDT
Andy: something very very weird is going on here. This bug was originally filed
against FC5 and system-config-kickstart (both of which states I have just
restored). Somehow it got incorrectly moved to system-config-display (which is
wrong) and associated with FC4test3 (which is wrong). I can see how this led to
confusion.

The reason I'm bringing it to your attention is that I'm wondering how the bug
got misfiled. I'm pretty sure that I didn't file it that badly.
Comment 7 Jonathan S. Shapiro 2006-07-26 11:06:28 EDT
Hmm. Also, I apologize for the "didn't read carefully enough" comment. Given
that the original bug was misfiled, you definitely didn't have enough context to
decipher what the heck I was talking about. Sorry -- not enough sleep and I
should know better.
Comment 8 Chris Lumens 2006-07-27 17:53:31 EDT
Added to the resolution list in system-config-kickstart.  The firstboot display
module is currently disabled because we're using X autoconfiguration now, so
that's no longer an issue.

Note You need to log in before you can comment on or make changes to this bug.