Bug 1565892 - One Time Password - OTP on Satellite *webUI and/or CLI* / subscription-manager failing when registering a new Content Host
Summary: One Time Password - OTP on Satellite *webUI and/or CLI* / subscription-manage...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Registration
Version: 6.2.14
Hardware: All
OS: All
unspecified
high
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Stephen Wadeley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 02:10 UTC by Waldirio M Pinheiro
Modified: 2019-12-03 12:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-03 12:53:38 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Waldirio M Pinheiro 2018-04-11 02:10:10 UTC
Description of problem:
Customer has OTP on their environment and working on Satellite. Works as expected to login via webUI but now customer would like to register a new content host *subscription-manager register --org="<org name here>"*. At this moment this process fail with message below

---
# subscription-manager register --org="<removed org name>"
Registering to: <servernameremove>:443/rhsm
Username: <omitted>
Password:
Unauthorized: Invalid credentials for request.
---

Version-Release number of selected component (if applicable):
6.2.14

How reproducible:
100% on Customer environment

Steps to Reproduce:
1.
2.
3.

Actual results:
---
# subscription-manager register --org="<removed org name>"
Registering to: <servernameremove>:443/rhsm
Username: <omitted>
Password:
Unauthorized: Invalid credentials for request.
---

Expected results:
Register the new Content Host without issue.

Additional info:

Comment 4 Bryan Kearney 2019-11-04 14:34:05 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 5 Bryan Kearney 2019-12-03 12:53:38 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.