Bug 1565895 - please retire pywebkitgtk for F28 [NEEDINFO]
Summary: please retire pywebkitgtk for F28
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pywebkitgtk
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F31FailsToInstall PY2FTBI F28FailsToInstall F29FailsToInstall F30FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2018-04-11 02:12 UTC by Sergio Basto
Modified: 2019-06-23 21:19 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-23 21:19:35 UTC
Type: Bug
mhroncok: needinfo? (extras-orphan)


Attachments (Terms of Use)

Description Sergio Basto 2018-04-11 02:12:13 UTC
pywebkitgtk no longer works because depends on retired webkit1 [1] 


[1]
import webkit
ImportError: libwebkitgtk-1.0.so.0: cannot open shared object file: No such file or directory

Comment 1 Jan ONDREJ 2018-05-05 15:39:31 UTC
And also unable to install it on F28:

 Problem: conflicting requests
  - nothing provides libjavascriptcoregtk-1.0.so.0()(64bit) needed by pywebkitgtk-1.1.8-13.fc26.x86_64

Comment 2 Miro Hrončok 2019-04-22 13:09:10 UTC
This is not installable on any Fedora version.

Please retire the package or fix this.

$ mock -r fedora-29-x86_64 install pywebkitgtk
...
Error: 
 Problem: conflicting requests
  - nothing provides libjavascriptcoregtk-1.0.so.0()(64bit) needed by pywebkitgtk-1.1.8-13.fc26.x86_64
  - nothing provides libwebkitgtk-1.0.so.0()(64bit) needed by pywebkitgtk-1.1.8-13.fc26.x86_64


$ mock -r fedora-rawhide-x86_64 install pywebkitgtk
...
Error: 
 Problem: conflicting requests
  - nothing provides libjavascriptcoregtk-1.0.so.0()(64bit) needed by pywebkitgtk-1.1.8-13.fc26.x86_64
  - nothing provides libwebkitgtk-1.0.so.0()(64bit) needed by pywebkitgtk-1.1.8-13.fc26.x86_64

Comment 3 Miro Hrončok 2019-04-29 20:06:09 UTC
A week has passed and this bug is still in the NEW state and the package does not install.

Please fix this or indicate that you are working ona  fix by setting the state to ASSIGNED.

After 3 such reminders, this package may be orphaned.

https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal#Removing_non-installable_packages_from_the_distro

Thanks

Comment 4 Ben Cotton 2019-05-02 19:37:50 UTC
This message is a reminder that Fedora 28 is nearing its end of life.
On 2019-May-28 Fedora will stop maintaining and issuing updates for
Fedora 28. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora 'version' of '28'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 28 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 5 Miro Hrončok 2019-06-23 21:19:35 UTC
Package got retired in rawhide.


Note You need to log in before you can comment on or make changes to this bug.