Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1565902 - java-1.8.0-openjdk-debug rpm is not updated in rhel7 base channel
Summary: java-1.8.0-openjdk-debug rpm is not updated in rhel7 base channel
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Lubomír Sedlář
QA Contact: Release Test Team
URL:
Whiteboard:
: 1892409 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 03:17 UTC by Amit Kumar Das
Modified: 2021-01-18 15:19 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-11 21:42:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3713431 0 None None None 2018-11-23 05:15:46 UTC

Description Amit Kumar Das 2018-04-11 03:17:22 UTC
Description of problem:

- "java-1.8.0-openjdk-debug" rpm is still in older version(1:1.8.0.77) in rhel-7-server-rpms channel.
- Whereas "java-1.8.0-openjdk" is in newer version(1:1.8.0.161) in rhel-7-server-rpms.

How reproducible:

//rhel-7-server-rpms  RedHat Enterprise Linux 7 Server//

java-1.8.0-openjdk.x86_64   		1:1.8.0.161-0.b14.el7_4      rhel-7-server-rpms
java-1.8.0-openjdk-debug.x86_64         1:1.8.0.77-0.b03.el7_2       rhel-7-server-rpms


//rhel-7-server-optional-rpms  RedHat Enterprise Linux 7 Server-Optional//

java-1.8.0-openjdk-debug.x86_64  1:1.8.0.161-2.b14.el7               rhel-7-server-optional-rpms

Actual results:

- Base channels contains
	openjdk	        1:1.8.0.161
	openjdk-debug	1:1.8.0.77

- Optional channels contains only 
	openjdk-debug   1:1.8.0.161


java-1.8.0-openjdk-debug is in older version in rhel7 base channel, and if we check the changelog, this package is not updated since "2016-03-23" in rhel base channel.

https://access.redhat.com/downloads/content/rhel---7/x86_64/2456/java-1.8.0-openjdk-debug/1.8.0.77-0.b03.el7_2/x86_64/fd431d51/package-changelog


Expected results:
openjdk-debug 1:1.8.0.161 should be included in rhel7 base channel with full support.


Additional info:
- Optional channel rpms is not supported by Redhat so expecting latest version to be added in RHEL base channel.

How are the Optional and Supplementary Channels supported 
https://access.redhat.com/articles/1150793

Comment 2 Lubos Kocman 2018-05-28 14:51:13 UTC
Agreed, this should be fixed. Ideally by moving package to base. As we've previously shipped it in base before.

Lubos

Comment 3 jiri vanek 2018-05-28 15:35:29 UTC
Debug packages must not go to base. Really must not.
They have absolute no support

Comment 6 Lubos Kocman 2018-11-07 14:05:31 UTC
Proposing to 7.7 as we haven't got all acks in 7.6 this should really get fixed.

Also confirming that this is still the case

lkocman@rcm-dev:rpmdiff_data> locate-rhel7-rpms-history openjdk-debug | grep -v debuginfo | grep 7.6
7.6 Client-optional/x86_64/os/Packages/java-1.8.0-openjdk-debug-1.8.0.181-7.b13.el7.i686.rpm
7.6 Client-optional/x86_64/os/Packages/java-1.8.0-openjdk-debug-1.8.0.181-7.b13.el7.x86_64.rpm
7.6 Client-optional/x86_64/os/Packages/java-11-openjdk-debug-11.0.ea.28-7.el7.i686.rpm
7.6 Client-optional/x86_64/os/Packages/java-11-openjdk-debug-11.0.ea.28-7.el7.x86_64.rpm
7.6 ComputeNode-optional/x86_64/os/Packages/java-1.8.0-openjdk-debug-1.8.0.181-7.b13.el7.i686.rpm
7.6 ComputeNode-optional/x86_64/os/Packages/java-1.8.0-openjdk-debug-1.8.0.181-7.b13.el7.x86_64.rpm
7.6 ComputeNode-optional/x86_64/os/Packages/java-11-openjdk-debug-11.0.ea.28-7.el7.i686.rpm
7.6 ComputeNode-optional/x86_64/os/Packages/java-11-openjdk-debug-11.0.ea.28-7.el7.x86_64.rpm
7.6 Server-optional/ppc64/os/Packages/java-1.8.0-openjdk-debug-1.8.0.181-7.b13.el7.ppc64.rpm
7.6 Server-optional/ppc64/os/Packages/java-11-openjdk-debug-11.0.ea.28-7.el7.ppc64.rpm
7.6 Server-optional/ppc64le/os/Packages/java-1.8.0-openjdk-debug-1.8.0.181-7.b13.el7.ppc64le.rpm
7.6 Server-optional/ppc64le/os/Packages/java-11-openjdk-debug-11.0.ea.28-7.el7.ppc64le.rpm
7.6 Server-optional/s390x/os/Packages/java-11-openjdk-debug-11.0.ea.28-7.el7.s390x.rpm
7.6 Server-optional/x86_64/os/Packages/java-1.8.0-openjdk-debug-1.8.0.181-7.b13.el7.i686.rpm
7.6 Server-optional/x86_64/os/Packages/java-1.8.0-openjdk-debug-1.8.0.181-7.b13.el7.x86_64.rpm
7.6 Server-optional/x86_64/os/Packages/java-11-openjdk-debug-11.0.ea.28-7.el7.i686.rpm
7.6 Server-optional/x86_64/os/Packages/java-11-openjdk-debug-11.0.ea.28-7.el7.x86_64.rpm
7.6 Workstation-optional/x86_64/os/Packages/java-1.8.0-openjdk-debug-1.8.0.181-7.b13.el7.i686.rpm
7.6 Workstation-optional/x86_64/os/Packages/java-1.8.0-openjdk-debug-1.8.0.181-7.b13.el7.x86_64.rpm
7.6 Workstation-optional/x86_64/os/Packages/java-11-openjdk-debug-11.0.ea.28-7.el7.i686.rpm
7.6 Workstation-optional/x86_64/os/Packages/java-11-openjdk-debug-11.0.ea.28-7.el7.x86_64.rpm
lkocman@rcm-dev:rpmdiff_data> 


Lubos

Comment 8 Amit Kumar Das 2019-04-24 01:26:13 UTC
Hi, Please confirm that this will be included in RHEL 7.7 release. Thanks

Comment 14 Tomas Borcin 2019-11-04 09:49:18 UTC

*** This bug has been marked as a duplicate of bug 1760414 ***

Comment 19 Mike Millson 2020-11-02 21:04:11 UTC
*** Bug 1892409 has been marked as a duplicate of this bug. ***

Comment 23 Chris Williams 2020-11-11 21:42:33 UTC
Red Hat Enterprise Linux 7 shipped it's final minor release on September 29th, 2020. 7.9 was the last minor releases scheduled for RHEL 7.
From intial triage it does not appear the remaining Bugzillas meet the inclusion criteria for Maintenance Phase 2 and will now be closed. 

From the RHEL life cycle page:
https://access.redhat.com/support/policy/updates/errata#Maintenance_Support_2_Phase
"During Maintenance Support 2 Phase for Red Hat Enterprise Linux version 7,Red Hat defined Critical and Important impact Security Advisories (RHSAs) and selected (at Red Hat discretion) Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available."

If this BZ was closed in error and meets the above criteria please re-open it flag for 7.9.z, provide suitable business and technical justifications, and follow the process for Accelerated Fixes:
https://source.redhat.com/groups/public/pnt-cxno/pnt_customer_experience_and_operations_wiki/support_delivery_accelerated_fix_release_handbook  

Feature Requests can re-opened and moved to RHEL 8 if the desired functionality is not already present in the product. 

Please reach out to the applicable Product Experience Engineer[0] if you have any questions or concerns.  

[0] https://bugzilla.redhat.com/page.cgi?id=agile_component_mapping.html&product=Red+Hat+Enterprise+Linux+7

Comment 26 Aashish Patil 2021-01-13 05:45:29 UTC
Hello,

One more Cu is looking for this.  This is regarding the Java-1.8.0-openjdk debug (Java-1.8.0-openjdk-debug and Java-1.8.0-openjdk-headless-debug) packages availability on RHEL 7.9 operating system.

Are there any updates on this?


Note You need to log in before you can comment on or make changes to this bug.