Bug 1565934 - RHV-H 4.1 "tuned-adm verify" command failed.
Summary: RHV-H 4.1 "tuned-adm verify" command failed.
Keywords:
Status: CLOSED DUPLICATE of bug 1564834
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor-ng
Version: 4.1.9
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Ryan Barry
QA Contact: cshao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 05:41 UTC by Sachin Raje
Modified: 2020-08-03 15:30 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-11 11:59:29 UTC
oVirt Team: Node
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3399201 0 None None None 2018-04-11 05:56:48 UTC

Description Sachin Raje 2018-04-11 05:41:45 UTC
Description of problem:
on RHVH 4.1 Host, "tuned-adm verify" verification command failed. 

Version-Release number of selected component (if applicable):
vdsm-4.19.36-1.el7ev.x86_64
tuned-2.8.0-5.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Login to RHVH 4.1 host as root user.
2. run command "tuned-adm verify".


Actual results:

# tuned-adm verify
Verification failed, current system settings differ from the preset profile.
You can mostly fix this by Tuned restart, e.g.:
  service tuned restart
Sometimes (if some plugins like bootloader are used) also reboot is required.
See tuned log file ('/var/log/tuned/tuned.log') for details.
----

The "/var/log/tuned/tuned.log" file contains following error :

2018-04-11 11:07:14,938 ERROR    tuned.plugins.base: verify: failed: 'vm.dirty_ratio' = '5', expected '40'
2018-04-11 11:07:14,971 ERROR    tuned.plugins.base: verify: failed: 'vm.dirty_background_ratio' = '2', expected '5'



Expected results:

# tuned-adm verify
Verfication succeeded, current system settings match the preset profile.
See tuned log file ('/var/log/tuned/tuned.log') for details.


Additional info:

# tuned-adm active
Current active profile: virtual-host

The "vm.dirty_ratio" and "vm.dirty_background_ratio" set by tuned 'virtual-host' profile. These values are overwritten by following vdsm settings.

-->
# cat /etc/sysctl.d/vdsm.conf  | grep vm.dirty
vm.dirty_ratio = 5
vm.dirty_background_ratio = 2
-->
================================

The tuned runs `sysctl --system` to reapply sysctl settings from sysctl.d, this can be changed in "/etc/tuned/tuned-main.conf" by setting reapply_sysctl = 0 (just remember to restart tuned and reapply the tuned profile).

So you need to make following changes in '/etc/tuned/tuned-main.conf',

1. open the file /etc/tuned/tuned-main.conf

reapply_sysctl = 1

Change it to 

reapply_sysctl = 0    <<==== change

Save the file.

2. Restart the tuned service,

# service tuned restart

3. Now run,

# tuned-adm verify

This should complete successfully.

Comment 3 Yaniv Kaul 2018-04-11 06:32:43 UTC
Duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1564834 ?

Comment 4 cshao 2018-04-11 09:29:10 UTC
Test version:
rhvh-4.1-0.20180410.0+1

# tuned-adm verify
Verification failed, current system settings differ from the preset profile.
You can mostly fix this by restarting the Tuned daemon, e.g.:
  systemctl restart tuned
or
  service tuned restart
Sometimes (if some plugins like bootloader are used) a reboot may be required.
See tuned log file ('/var/log/tuned/tuned.log') for details.

Can reproduce this issue.

Comment 5 Ryan Barry 2018-04-11 11:59:29 UTC
Definitely a duplicate

*** This bug has been marked as a duplicate of bug 1564834 ***

Comment 6 Franta Kust 2019-05-16 13:09:35 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.