Bug 1565963 - [Docs][RFE][Admin] Tunneling network change
Summary: [Docs][RFE][Admin] Tunneling network change
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.2.0
Hardware: All
OS: Unspecified
medium
high
Target Milestone: ovirt-4.2.3
: ---
Assignee: Avital Pinnick
QA Contact: Tahlia Richardson
URL:
Whiteboard: docs-accepted
: 1560870 1565542 (view as bug list)
Depends On: 1565109
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 07:58 UTC by Marcin Mirecki
Modified: 2019-05-07 12:45 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-10 07:40:39 UTC
oVirt Team: Docs
Target Upstream Version:


Attachments (Terms of Use)

Description Marcin Mirecki 2018-04-11 07:58:17 UTC
Updating ovirt network used for OVN tunnel needs to be added to the docs.
Description below:

When a host is installed, it uses the "ovirtmgmt" network to set up
OVN tunnels (connecting the OVN hosts).
But, the user might want to use another network for this purpose.
This can be done by executing the "ovirt-provider-ovn-driver" ansible playbook
from the engine host, to change the configuation for all hosts in a cluster.
Steps:

1. Go to:
cd /usr/share/ovirt-engine/playbooks

2. Execute:
ansible-playbook --private-key=/etc/pki/ovirt-engine/keys/engine_id_rsa -i /usr/share/ovirt-engine-metrics/bin/ovirt-engine-hosts-ansible-inventory --extra-vars " cluster_name=<cluster name> ovn_central=<ovn central ip> ovn_tunneling_interface=<vdsm network name>" ovirt-provider-ovn-driver.yml

For example, for the following parameters:
  cluster: TEST_CLUSTER
  network: TEST_NETWORK
  ovn central ip: 192.168.0.1
the command will be:
ansible-playbook --private-key=/etc/pki/ovirt-engine/keys/engine_id_rsa -i /usr/share/ovirt-engine-metrics/bin/ovirt-engine-hosts-ansible-inventory --extra-vars " cluster_name=TEST_CLUSTER ovn_central=192.168.0.1 ovn_tunneling_interface=TEST_NETWORK" ovirt-provider-ovn-driver.yml

Note that "ovn_central" ip can, but does not have to be on the new network. The only requirement is that is has be reachable from all hosts.

Note that this only changes the settings on existing hosts. If new hosts are
added to the cluster, the procedure has to be repeated.


The OVN tunnel network can also be changed on an individual host by invoking:
vdsm-tool ovn-config <ovn central ip> <tunneling ip or network name>

Comment 1 Marcin Mirecki 2018-04-11 08:10:52 UTC
*** Bug 1565542 has been marked as a duplicate of this bug. ***

Comment 2 Lucy Bopf 2018-04-13 05:28:54 UTC
Marcin, is this change recorded in an engineering RFE? If so, can you provide the BZ number. Thanks!

Comment 3 Marcin Mirecki 2018-04-13 07:49:50 UTC
This is the dev bz:
https://bugzilla.redhat.com/1565109

Comment 4 Avital Pinnick 2018-04-13 12:34:07 UTC
*** Bug 1560870 has been marked as a duplicate of this bug. ***

Comment 5 Dan Kenigsberg 2018-04-16 09:32:46 UTC
Raising severity, as any serious OVN user would NOT like to use the management network for tunneling.

Comment 7 Lucy Bopf 2018-04-20 04:26:43 UTC
Officially accepting this into our GA program.

Comment 13 Avital Pinnick 2018-05-02 07:19:48 UTC
Will be published with 4.2 GA documents


Note You need to log in before you can comment on or make changes to this bug.