Bug 1566006 - 'dnf updateinfo --list updates' crashes
Summary: 'dnf updateinfo --list updates' crashes
Status: CLOSED DUPLICATE of bug 1545075
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 10:28 UTC by Stanislav Kontar
Modified: 2018-04-11 11:57 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-04-11 11:57:50 UTC


Attachments (Terms of Use)

Description Stanislav Kontar 2018-04-11 10:28:10 UTC
Description of problem:
When I run 'dnf updateinfo --list updates', it crashes.

Version-Release number of selected component (if applicable):
2.7.5

How reproducible:
Always


Steps to Reproduce:
1. dnf updateinfo --list updates

Actual results:
$ dnf updateinfo --list updates
Last metadata expiration check: 0:01:03 ago on Wed 11 Apr 2018 12:24:51 PM CEST.
Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 179, in user_main
    errcode = main(args)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 115, in cli_run
    cli.run()
  File "/usr/lib/python3.6/site-packages/dnf/cli/cli.py", line 1014, in run
    return self.command.run()
  File "/usr/lib/python3.6/site-packages/dnf/cli/commands/updateinfo.py", line 417, in run
    display(apkg_adv_insts, mixed, description)
  File "/usr/lib/python3.6/site-packages/dnf/cli/commands/updateinfo.py", line 292, in display_list
    for (nevra, inst), id2type in cls._list(apkg_adv_insts))
  File "/usr/lib/python3.6/site-packages/dnf/cli/commands/updateinfo.py", line 292, in <genexpr>
    for (nevra, inst), id2type in cls._list(apkg_adv_insts))
  File "/usr/lib/python3.6/site-packages/dnf/cli/commands/updateinfo.py", line 290, in <genexpr>
    for id_, (typ, sev) in id2type.items()),
  File "/usr/lib/python3.6/site-packages/dnf/cli/commands/updateinfo.py", line 283, in type2label
    return (cls.SECURITY2LABEL[sev] if typ == hawkey.ADVISORY_SECURITY
KeyError: 'None'


Expected results:
No exception, list of updates.

Additional info:
N/A

Comment 1 Marek Blaha 2018-04-11 11:57:50 UTC

*** This bug has been marked as a duplicate of bug 1545075 ***


Note You need to log in before you can comment on or make changes to this bug.