Bug 1566012 - Kuryr does not use Octavia API directly
Summary: Kuryr does not use Octavia API directly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-kuryr-kubernetes
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Antoni Segura Puimedon
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 10:54 UTC by Tomas Sedovic
Modified: 2018-06-27 13:51 UTC (History)
5 users (show)

Fixed In Version: openstack-kuryr-kubernetes-0.4.2-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:50:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1763045 None None None 2018-04-11 15:54:34 UTC
OpenStack gerrit 560433 None master: MERGED kuryr-kubernetes: lbaasv2: Fix for deployments missing the proxy (Iafd74f23bdf336a4d78ba4759f702cf989c8bc30) 2018-04-24 16:57:52 UTC
OpenStack gerrit 561974 None stable/queens: MERGED kuryr-kubernetes: lbaasv2: Fix for deployments missing the proxy (Iafd74f23bdf336a4d78ba4759f702cf989c8bc30) 2018-04-24 16:57:46 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:51:40 UTC

Description Tomas Sedovic 2018-04-11 10:54:00 UTC
Description of problem:

When using Kuryr on OSP 13 (with Octavia) it should talk to the Octavia API directly, instead of using the lbaasv2 API and endpoint in Neutron.

See: https://bugzilla.redhat.com/show_bug.cgi?id=1564188

This means that creating kubernetes services (which use Octavia behind back).

Version-Release number of selected component: 0.4.1

How reproducible: Always

Steps to Reproduce:
1. Get OSP 13 with Octavia
2. Install OCP with Kuryr
3. Create a pod which results in a kubernetes service creation

Actual results:
The service will not be created because the Octavia loadbalancer creation will fail.

Expected results:
The service will be created and working properly.

Additional info:

Comment 9 Jon Uriarte 2018-04-30 16:12:47 UTC
Verified in:
openstack-kuryr-kubernetes-common-0.4.2-1.el7ost.noarch
openstack-kuryr-kubernetes-controller-0.4.2-1.el7ost.noarch

The kubernetes service is correctly created and accessed.

Comment 11 errata-xmlrpc 2018-06-27 13:50:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.