Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1566033 - [DOCS] crio service not running when configuring crio
Summary: [DOCS] crio service not running when configuring crio
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Chris Negus
QA Contact: Vikram Goyal
Vikram Goyal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 11:55 UTC by raffaele spazzoli
Modified: 2018-11-15 14:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-15 14:43:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description raffaele spazzoli 2018-04-11 11:55:15 UTC
Description of problem:
I configured an OpenShift ansible installation with crio
openshift_use_crio: true
openshift_crio_enable_docker_gc: true 

When the installer tried to start the nodes it failed on all on them.
This is the node service log:

36:13.866837   33661 remote_runtime.go:43] Connecting to runtime service /var/run/crio/crio.sock
36:13.866861   33661 util_unix.go:75] Using "/var/run/crio/crio.sock" as endpoint is deprecated, please consider using full url format "unix:///var/run/crio/crio.sock".
36:13.866966   33661 util_unix.go:75] Using "/var/run/crio/crio.sock" as endpoint is deprecated, please consider using full url format "unix:///var/run/crio/crio.sock".
36:13.877418   33661 remote_runtime.go:69] Version from runtime service failed: rpc error: code = Unavailable desc = grpc: the connection is unavailable
36:13.877502   33661 kuberuntime_manager.go:172] Get runtime version failed: rpc error: code = Unavailable desc = grpc: the connection is unavailable
36:13.877524   33661 server.go:173] failed to run Kubelet: failed to create kubelet: rpc error: code = Unavailable desc = grpc: the connection is unavailable
ce: main process exited, code=exited, status=255/n/a
ode.
service entered failed state.

on firther investigation it looks like crio is not even installed and the crio service is not started:

[root@env1-master-m7zc ~]# rpm -qa | grep cri-o
[root@env1-master-m7zc ~]# systemctl status crio
Unit crio.service could not be found.


Version-Release number of selected component (if applicable):
atomic-openshift-node-3.9.14-1.git.0.4efa2ca.el7.x86_64

How reproducible:
not sure. 100% on my setup.


Steps to Reproduce:
I can share my inventory if needed.

Actual results:
node service doesn't start.

Expected results:
crio service is running, node service can start, containers can be started.

Comment 2 raffaele spazzoli 2018-04-12 00:32:49 UTC
I understood what is going on. In order for the ansible installer to be successful the cri-o rpm must be installed and the crio.service must be started.

This bugzilla should be turned into a documentation bug. The host prep section of the documentation should mention to perform the above steps when planning to use crio.

Comment 3 Chris Negus 2018-11-15 14:43:00 UTC
We just published a new CRI-O guide that, I believe, has the proper ansible settings to make an OpenShift installation with CRI-O nodes work properly:

    https://access.redhat.com/documentation/en-us/openshift_container_platform/3.11/html-single/cri-o_runtime/

The guide also has configuration and troubleshooting sections. If there are issues that we have missed, please open another bug against that document.


Note You need to log in before you can comment on or make changes to this bug.