Bug 1566039 - Service Catalog is not HA
Summary: Service Catalog is not HA
Keywords:
Status: CLOSED DUPLICATE of bug 1554623
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Catalog
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Paul Morie
QA Contact: Zhang Cheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 12:01 UTC by Nicholas Schuetz
Modified: 2018-04-11 13:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-11 13:57:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Nicholas Schuetz 2018-04-11 12:01:23 UTC
The service catalog apiserver and controller are deployed as daemonsets to the first master only.

An HA mode cluster will be crippled if you shutdown the master which has these daemonsets deployed.  IMHO, we should do one of two things:

1)  make them normal pods so they can be migrated in cases of failure
or
2)  deploy the daemonset to each master (instead of only master01).


[root@master01 ~]# oc get pods --all-namespaces -owide |grep catalog
kube-service-catalog                apiserver-jcb4w                               1/1       Running     1          22h       10.129.0.16   master01.ocp.nicknach.net
kube-service-catalog                controller-manager-9pwg7                      1/1       Running     2          22h       10.129.0.18   master01.ocp.nicknach.net

one hour later, after shutting down master01:

[root@master02 ~]# oc get pods --all-namespaces -owide |grep catalog
kube-service-catalog                apiserver-jcb4w                               1/1       NodeLost    1          23h       10.129.0.16   master01.ocp.nicknach.net
kube-service-catalog                controller-manager-9pwg7                      1/1       NodeLost    2          23h       10.129.0.18   master01.ocp.nicknach.net

-Nick

Comment 1 Jeff Peeler 2018-04-11 13:57:50 UTC

*** This bug has been marked as a duplicate of bug 1554623 ***


Note You need to log in before you can comment on or make changes to this bug.