Bug 1566060 - [UI] - VM > Start Running On host > Specific host field is disabled if pressing next to the 'Any Host In Cluster radio button
Summary: [UI] - VM > Start Running On host > Specific host field is disabled if pressi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.2.6
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ovirt-4.3.0
: 4.3.0
Assignee: Tomas Jelinek
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 12:46 UTC by Michael Burman
Modified: 2019-02-13 07:46 UTC (History)
4 users (show)

Fixed In Version: ovirt-engine-4.3.0_alpha
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-13 07:46:48 UTC
oVirt Team: Virt
rule-engine: ovirt-4.3+


Attachments (Terms of Use)
record (1.79 MB, application/x-gzip)
2018-04-11 12:46 UTC, Michael Burman
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90443 0 master MERGED webadmin: removed un-needed listener 2018-04-18 13:11:02 UTC

Description Michael Burman 2018-04-11 12:46:03 UTC
Created attachment 1420286 [details]
record

Description of problem:
[UI] - VM > Start Running On host > Specific host field is disabled if pressing next to the 'Any Host In Cluster radio button.

If choosing to run VM on a specific host in cluster and then by mistake pressing with the mouse cursor next to the "Any Host In Cluster' radio button, the 'Specific Host(s)' field suddenly become disabled and host can't be chosen.
It looks like the whole area next to the "Any Host In Cluster' radio button behaves like we pressed the radio button and it disables the 'Specific Host(s)' field.
The same bug applies for edit VM flow and Run Once VM flow.

Version-Release number of selected component (if applicable):
4.2.2.6-0.1.el7

How reproducible:
100%

Steps to Reproduce:
1. Run VM once or edit VM, choose to run on a specific host in cluster, don't approve operation yet
2. Press any where next to the "Any Host In Cluster' radio button, but not the radio button it self

Actual results:
'Specific Host(s)' field suddenly become disabled and host can't be chosen

Expected results:
Nothing should happen unless pressing the "Any Host In Cluster' radio button it self

Comment 1 Michal Skrivanek 2018-04-16 13:01:07 UTC
thoughts?

Comment 2 Tomas Jelinek 2018-04-18 10:46:28 UTC
simple fix - posted a patch to it.

Comment 3 Raz Tamir 2018-11-27 09:14:10 UTC
Verified on 4.3.0-0.5.alpha1.el7

Comment 4 Sandro Bonazzola 2019-02-13 07:46:48 UTC
This bugzilla is included in oVirt 4.3.0 release, published on February 4th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.0 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.