Bug 1566069 - Update openvswitch 2.10 to use DPDK 17.11.4 stable release
Summary: Update openvswitch 2.10 to use DPDK 17.11.4 stable release
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openvswitch
Version: 7.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Kevin Traynor
QA Contact: Jean-Tsung Hsiao
URL:
Whiteboard:
Depends On: 1631703
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 13:07 UTC by Kevin Traynor
Modified: 2019-01-02 17:54 UTC (History)
13 users (show)

Fixed In Version: openvswitch2.10-2.10.0-23.el7fdn
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-02 17:54:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0014 0 None None None 2019-01-02 17:54:52 UTC

Description Kevin Traynor 2018-04-11 13:07:40 UTC
DPDK 17.11.x stable releases contain the latest bug fixes.

Comment 2 Kevin Traynor 2018-04-11 13:12:14 UTC
Bugfixes between DPDK 17.11.0 and DPDK 17.11.1

d864d41 version: 17.11.1
16f117c net/mlx5: fix flow priority on queue action
9dd8bea net/mlx5: remove parser/flow drop queue
829da4b Revert "net/mlx5: fix flow priority on queue action"
adf59a9 eal/ppc64: revert arch-specific TSC freq query
3bdf790 net/bnxt: fix link speed setting with autoneg off
6f2b68d net/qede: fix clearing of queue stats
dedf7be net/qede/base: fix VF LRO tunnel configuration
0ec3529 net/mlx5: fix flow priority on queue action
ff24f85 net/mlx5: fix port stop by verify flows are still present
29dd3c6 net/mlx5: fix secondary process verification
3c2d2c1 Revert "net/mlx5: fix flow type for allmulti rules"
322e1ce net/mlx5: fix link state on device start
f1e3e97 net/mlx5: fix handling link status event
59f1ce1 ethdev: fix port id allocation
b7fc715 app/testpmd: fix flow director filter
c771a07 net/i40e: check multi-driver option parsing
ea61f8e net/bnxt: fix return code in MAC address set
8c22fe7 net/bnxt: fix Rx checksum flags
344d489 net/tap: fix cleanup on allocation failure
011d777 net/mlx5: use PCI address as port name
5e40fd1 net/i40e: fix Rx interrupt
12cd064 net/i40e: fix interrupt conflict with multi-driver
003151f net/i40e: fix multiple driver support
ab3218b net/i40e: add debug logs when writing global registers
14f82ac net/i40e: warn when writing global registers
b41928f Revert "ethdev: fix port id allocation"
a0249f2 net/dpaa: fix potential memory leak
7fb5e50 event/octeontx: fix Rx adapter port id mapping
96e21c8 net/octeontx: add channel to port id mapping
fb4c79d net/i40e: fix multiple DDP packages conflict
331d4df test/timer_perf: fix memory leak
bb09db9 test/table: fix memory leak
763a2d2 test/ring_perf: fix memory leak
3fb4d53 test/ring: fix memory leak
4c1392e test/reorder: fix memory leak
38efe08 test/bitmap: fix memory leak
ad2beec examples/ip_pipeline: fix timer period unit
d7eab3d bus/dpaa: fix default IOVA mode
6174c13 bus/fslmc: fix build with latest glibc
1c5819e app/testpmd: fix port topology in RSS forward config
1e1f3b9 app/testpmd: fix port index in RSS forward config
ffb48e8 net/mlx5: fix UAR remapping on non configured queues
5c35c2f net/mlx5: fix flow RSS configuration
5d5091c net/mlx4: fix Rx offload non-fragmented indication
55811ba vhost: remove pending IOTLB entry if miss request failed
2f6b2ae vhost: fix IOTLB pool out-of-memory handling
a872346 net/qede: fix few log messages
47961e7 net/bonding: check error of MAC address setting
f014d69 net/mlx4: fix drop flow resources leak
64d1384 usertools/devbind: fix kernel module reporting
8b4341b mempool: fix physical contiguous check
abb25d6 bus/vdev: continue probing after a device failure
f8e8bb5 mk: fix external build
3d2804b examples/bond: check mbuf allocation
2221b1a crypto/qat: fix allocation check and leak
6315203 examples/bond: fix vdev name
bf54e2d net/ixgbe: fix reset error handling
188fa96 app/testpmd: fix port validation
67abe74 ethdev: fix port id allocation
75b1eaf ethdev: fix port data reset timing
a8eae22 crypto/scheduler: fix strncpy
2111436 mk: support renamed Makefile in external project
cb524bc crypto/dpaa2_sec: fix enum conversion for GCM
5630769 eal/ppc: remove the braces in memory barrier macros
40a6c11 net/qede: fix MTU set and max Rx length
07f1141 net/qede: fix tunnel header size in Tx BD configuration
c55f999 net/qede: check tunnel L3 header
9c0a1bf net/bnxt: fix number of pools for RSS
601ef07 net/bnxt: fix size of Tx ring in HW
8208b72 net/e1000: fix VF Rx interrupt enabling
1e3e479 net/ixgbe: fix VF Rx interrupt enabling
0b09a23 net/i40e: fix VF Rx interrupt enabling
f0d46b0 net/virtio: fix memory leak when reinitializing device
cdf245d net/virtio: fix queue flushing with vector Rx enabled
3d735b4 net/virtio: fix Rx and Tx handler selection for ARM32
0555018 net/virtio-user: fix crash as features change
2cdcc8b net/ena: do not set Tx L4 offloads in Rx path
d01327d net/mlx5: fix memory region boundary checks
1eee333 net/mlx5: fix memory region cache last index
d4192ea net/mlx5: fix memory region cache lookup
e93a85e net/mlx5: fix flow item validation
1468154 net/mlx5: fix missing RSS capability
b520dc4 net/i40e: fix memory leak
76f8876 net/e1000: fix null pointer check
acc4c80 net/enic: fix crash due to static max number of queues
961c2a9 net/mlx5: fix return value of start operation
a50d7a4 crypto/qat: fix null auth algo overwrite
8828baa cryptodev: fix session pointer cast
5be0172 crypto/qat: fix parameter type
5e78a44 crypto/qat: fix out-of-bounds access
09c8e4a mbuf: fix NULL freeing when debug enabled
6b297eb eal/arm64: remove the braces in memory barrier macros
7b1dff5 log: fix memory leak in regexp level set
0197da7 keepalive: fix state alignment
32f3430 cmdline: avoid garbage in unused fields of parsed result
abab057 cmdline: fix dynamic tokens parsing
0fddb78 service: fix possible mem leak on initialize
daaab9d event/sw: fix debug logging config option
cfa5d02 Revert "net/mlx5: fix IPv6 header fields"
287c330 net/mlx5: fix memory region lookup
e1497f0 net/i40e: fix flow director Rx resource defect
ed9d935 net/failsafe: fix invalid free
7320ecf vhost: protect active rings from async ring changes
7fbee65 vhost: fix mbuf free
1403ac5 net/sfc: fix flow RSS check in error handling
c0010ad net/sfc: fix initialization of flow structure
7e66ddb net/mlx5: fix IPv6 header fields
1790f11 net/i40e: fix packet type for X722
311d00f net/i40e: fix flag for MAC address write
e10fc77 net/qede: replace config option with run-time arg
88fca1f examples/ipsec-secgw: fix SPI byte order in flow item
0021bc8 net: fix ESP header byte ordering definition
e6d5887 examples/ipsec-secgw: fix missing ingress flow attribute
5ffea06 examples/ipsec-secgw: fix corner case for SPI value
f848f83 cryptodev: fix function prototype
3892ca5 cryptodev: add missing CPU flag string
104c741 security: fix enum start value
bae9a32 security: fix pedantic compilation
8e4a932 crypto: fix pedantic compilation
f002308 security: fix device operation type
e9b0d68 examples/ipsec-secgw: fix usage of incorrect port
bbf3505 test/crypto: fix missing include
b3a0d8d doc: fix format in OpenSSL installation guide
4c54887 doc: fix lists of supported crypto algorithms
781bb36 bus/pci: forbid IOVA mode if IOMMU address width too small
94f0bd3 eventdev: fix doxygen comments
e076082 event/sw: fix queue memory leak and multi-link bug
ca48a0e test/eventdev: use CPU event type
7f51a96 eventdev: set error code in port link/unlink functions
65680e0 member: fix memory leak on error
6633879 mempool/octeontx: fix natural alignment being optimized out
7a2018b mbuf: fix performance of freeing with non atomic refcnt
ea5851a test/memzone: fix freeing test
1eb88d9 test/memzone: fix NULL freeing
6bcf30e test/memzone: fix wrong test
6bbf994 test/table: fix uninitialized parameter
4fff158 test: register test as failed if setup failed
ef23d01 app/procinfo: add compilation option in config
af9adf3 app/testpmd: fix invalid Tx queue number setting
0e9fb99 app/testpmd: fix invalid Rx queue number setting
460811f pdump: fix error check when creating/canceling thread
1408cbb igb_uio: allow multi-process access
340edf8 lib: fix missing includes in exported headers
9d9009f member: fix ISO C in exported header
3ed245a flow_classify: fix ISO C in exported header
4c0428e net/i40e: fix ISO C in exported header
d8a8ab7 examples/vhost: fix startup check
8c808d6 vhost: fix error code check when creating thread
582c879 net/mlx5: fix calculation of flow ID flag
130943c net/mlx5: fix missing attribute size for drop action
328e449 net/mlx5: fix deadlock of link status alarm
54fbf3a net/i40e: fix VF reset stats crash
aca851c net/i40e: fix port segmentation fault when restart
9e61511 net/i40e: fix setting MAC address of VF
54e4df5 net/ixgbe: fix max queue number for VF
ad27397 net/mrvl: keep shadow Txqs inside PMD Txq
25c3a8e net/mrvl: fix shadow queue tail and size calculations
63d51dc net/mrvl: fix oversize bpool handling
cbeedfb net/mrvl: fix HIF objects allocation
a0d1bff net/mrvl: fix multiple probe
ccfb29c net/tap: remove unused kernel version definitions
963fc04 net/failsafe: fix Rx safe check compiler hint
a19d236 net/pcap: fix the NUMA id display in logs
f596cb1 net/enic: fix L4 Rx ptype comparison
5e81dd4 ethdev: fix link autonegotiation value
ee0caa0 net/bonding: fix setting slave MAC addresses
f6aa477 net/bnxt: free the aggregation ring
3ba9e94 net/bnxt: fix duplicate pattern for 5tuple filter
d7e26b9 net/bnxt: fix duplicate filter pattern creation error
8c4a8ab net/bnxt: fix check for ether type
e33676f net/bnxt: fix group info usage
3e760c3 net/bnxt: parse checksum offload flags
8d6d622 net/bnxt: fix double increment of idx during Tx ring alloc
4d030ae net/dpaa: fix FW version code
5af0f69 net/dpaa: fix the mbuf packet type if zero
7598589 net/dpaa: fix uninitialized and unused variables
b10e1c8 net/mlx5: fix overwriting bit-fields in SW Rx queue
703c9b1 net/i40e: fix VSI MAC filter on primary address change
479eac0 net/ixgbe: fix the failure of number of Tx queue check
5f30a17 net/i40e: exclude LLDP packet count
240f37d net/i40e: fix FDIR rule confiliction issue
c72d58b net/ixgbe: fix parsing FDIR NVGRE issue
2869fb4 net/sfc: fix incorrect bitwise ORing of L3/L4 packet types
06fde05 net/sfc: do not hold management event queue lock while MCDI
771fa08 net/sfc: fix label name to be consistent
7ebd90a examples/vhost: fix sending ARP packet to self
f1fd54f net/virtio: fix typo in LRO support
82b3cc8 net/virtio: fix vector Rx flushing
faee066 net/virtio: fix incorrect cast
4e3a3ed vhost: fix dequeue zero copy with virtio1
e1fd3c6 vhost: fix crash
1bbd934 net/i40e: fix setting of MAC address on i40evf
fbc9176 net/i40e: add FDIR NVGRE parameter check
6f0ac97 net/ixgbe: fix tunnel filter fail problem
e31777d net/i40e: fix FDIR input set conflict
8cfbfab net/i40e: fix VLAN offload setting issue
2b59636 net/igb: fix Tx queue number assignment
339d966 net/ixgbe: fix wrong PBA setting
4a8cdc6 net/fm10k: fix logical port delete
d43014c net/i40e: fix VLAN offload setting
a003543 net/mlx5: fix un-supported RSS hash fields use
37c5da4 net/mlx5: fix HW checksum offload for outer IP
c1253af net/mlx5: fix RSS key configuration
eda82c9 net/mlx5: fix overflow of Memory Region cache
adb951a net/mlx5: fix Memory Region registration
2e82fea net/mlx5: fix VLAN configuration after port stop
3e73ef4 net/sfc: fix main MAC address handling
5537bb1 ethdev: fix missing imissed counter in xstats
7bde417 net/sfc: fix DMA memory leak after kvarg processing failure
c741311 net/sfc: fix multicast address list copy memory leak
49abd18 net/sfc: stop periodic DMA if MAC stats upload fails
5e9f158 net/qede: fix to reject config with no Rx queue
35d796a net/qede: fix to enable LRO over tunnels
12cd8fb net/bonding: fix activated slave in 8023ad mode
d887683 net/mlx4: fix Tx packet drop application report
b187189 net/mlx5: fix flow type for allmulti rules
92a6ceb net/mlx4: revert workaround for broken Verbs
3250964 drivers: change the deprecated memseg physaddr to IOVA
0e5db82 bus/fslmc: fix the cplusplus macro closure
f23f5e9 net/szedata2: fix check of mmap return value
4fa69fa net/mlx4: fix unnecessary include
6c337e3 net/mlx5: fix Tx checksum offloads
0709630 net/thunderx: fix multi segment Tx function return
fdad105 net/nfp: fix CRC strip check behaviour
03e87d1 net/nfp: fix jumbo settings
75dba73 net/nfp: fix MTU settings
577e1ac net/bonding: fix bonding in 8023ad mode
c6a459e net/mlx5: cleanup allocation of ethtool stats
f95a501 timer: fix reset on service cores
39d6705 examples/l3fwd-power: fix frequency detection
6f41a18 examples/l3fwd-power: fix Rx without interrupt
45954b8 app/testpmd: fix flowgen forwarding offload flags
b151124 app/testpmd: fix port configuration print
8b81a1f mempool/octeontx: fix memory area registration
067290d mempool: fix first memory area notification
d925af2 mempool/octeontx: fix improper memory barrier
dab3512 net/ixgbe: fix ARM big endian build
dd18ba5 net/i40e: fix ARM big endian build
a9cc5ad bus/dpaa: fix ARM big endian build
31df973 lpm: fix ARM big endian build
13d57a9 pmdinfogen: fix cross compilation for ARM big endian
c9a6a40 vfio: fix enabled check on error
8430a91 malloc: fix end for bounded elements
fa38beb malloc: protect stats with lock
e0246c9 memzone: fix leak on allocation error
295c63b bus/pci: fix interrupt handler type
5f08be4 service: fix service core launch
7a393b2 service: fix lcore role after delete
b431891 service: fix number mapped cores count
c23404e kni: fix build dependency
6a08ab3 app/testpmd: fix crash of txonly with multiple segments
51f4b25 app/testpmd: fix port id allocation
b1d6ccf bus/dpaa: fix build when assert enabled
2583f75 mk: remove TILE-Gx machine type
ce10271 app/testpmd: remove xenvirt again
c4b6050 kni: fix build with kernel 4.15

Comment 3 Eelco Chaudron 2018-04-11 13:15:22 UTC
*** Bug 1565753 has been marked as a duplicate of this bug. ***

Comment 8 Kevin Traynor 2018-11-06 15:21:35 UTC
Updated to latest stable release DPDK 17.11.4

Comment 12 Kevin Traynor 2018-12-13 14:38:09 UTC
Hi Ioanna, the simple doc update for this Bz looks good.

Kevin.

Comment 15 errata-xmlrpc 2019-01-02 17:54:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0014


Note You need to log in before you can comment on or make changes to this bug.