Bug 1566080 - [Infra] Improve TripleO OpenDaylight healthcheck to use new status URL instead of neutron (ODL part)
Summary: [Infra] Improve TripleO OpenDaylight healthcheck to use new status URL instea...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z3
: 13.0 (Queens)
Assignee: Michael Vorburger
QA Contact: Tomas Jamrisko
URL:
Whiteboard: Infra
: 1638702 (view as bug list)
Depends On:
Blocks: 1488907 1577853
TreeView+ depends on / blocked
 
Reported: 2018-04-11 13:26 UTC by Michael Vorburger
Modified: 2018-11-19 12:22 UTC (History)
10 users (show)

Fixed In Version: opendaylight-8.3.0-4.el7ost
Doc Type: Bug Fix
Doc Text:
The docker healthcheck for OpenDaylight ensured only that the REST interface and neutron NB component was healthy in OpenDaylight. The healthcheck did not include all loaded OpenDaylight components and therefore was not accurate. Use diagstatus URI with docker healthcheck to check all of the loaded OpenDaylight components. OpenDaylight docker container health status is now more accurate.
Clone Of:
Environment:
Last Closed: 2018-11-13 23:32:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenDaylight Bug INFRAUTILS-33 None None None 2018-04-11 13:26:52 UTC
OpenDaylight Bug INFRAUTILS-46 None None None 2018-08-21 21:46:43 UTC
OpenDaylight Bug INFRAUTILS-47 None None None 2018-08-21 21:48:57 UTC
OpenDaylight Bug INFRAUTILS-48 None None None 2018-08-22 23:16:26 UTC
OpenDaylight gerrit 73241 None None None 2018-06-28 14:43:19 UTC
OpenDaylight gerrit 73242 None None None 2018-06-28 14:42:41 UTC
OpenDaylight gerrit 73243 None None None 2018-06-28 14:41:50 UTC
OpenDaylight gerrit 73265 None None None 2018-06-28 14:40:59 UTC
Red Hat Product Errata RHBA-2018:3614 None None None 2018-11-13 23:34:31 UTC

Description Michael Vorburger 2018-04-11 13:26:53 UTC
Following up on bug 1549218, we will be changing the TripleO OpenDaylight healthcheck from the /controller/nb/v2/neutron URL to the better status URL which will be exposed in ODL upstream by https://jira.opendaylight.org/browse/INFRAUTILS-33.

Comment 2 Michael Vorburger 2018-04-23 09:35:53 UTC
The new INFRAUTILS-33 OpenDaylight status /diagstatus URL healthcheck is dev complete upstream in ODL, and about to be merged there.  This BZ issue should then be re-assigned to someone else than me who can take care of the required TripleO healthcheck URL change and impact handling.

Comment 10 Tim Rozet 2018-08-21 21:44:25 UTC
The current implementation needs some more fixes. The status returned should be 503 Service unavailable. Right now HTTP GET always returns 200, and HTTP HEAD gives 418 and then hangs when a node is isolated:

[root@controller-0 ~]# curl -i -X GET http://172.17.1.14:8081/diagstatus && curl -i -X HEAD http://172.17.1.14:8081/diagstatus --max-time 5
HTTP/1.1 200 OK
Content-Type: application/json;charset=utf-8
Content-Length: 132

{
  "timeStamp": "Tue Aug 21 21:20:07 UTC 2018",
  "isOperational": false,
  "systemReadyState": "FAILURE",
  "statusSummary": []
}
HTTP/1.1 418 418
Content-Type: application/json;charset=utf-8
Content-Length: 132

curl: (28) Operation timed out after 5001 milliseconds with 0 out of 132 bytes received

Comment 13 Michael Vorburger 2018-08-22 23:00:45 UTC
Fixes have just been proposed upstream, and should trickle downstream eventually.

Comment 15 Stephen Kitt 2018-08-27 13:21:35 UTC
The patches have been back-ported d/s https://code.engineering.redhat.com/gerrit/#/q/topic:1566080+(status:open+OR+status:merged) but we'll get them for free the next time we rebase on Oxygen.

Comment 17 Lon Hohberger 2018-09-18 10:36:59 UTC
According to our records, this should be resolved by opendaylight-8.3.0-3.el7ost.  This build is available now.

Comment 19 Michael Vorburger 2018-09-27 10:43:08 UTC
> https://bugzilla.redhat.com/show_bug.cgi?id=1488907#c39

(In reply to Lon Hohberger from comment #17)
> According to our records, this should be resolved by
> opendaylight-8.3.0-3.el7ost.  This build is available now.

Lon, looks like you got this wrong, could that be?  According to https://brewweb.engineering.redhat.com/brew/packageinfo?packageID=54522 (which Tomas just showed me), opendaylight-8.3.0-3.el7ost was built on 2018-08-07 but https://code.engineering.redhat.com/gerrit/#/c/148168/ (and the others listed above) were only merged Sep 5 - so this didn't make it into 8.3.0-3 but 8.3.0-4.... I'm therefore adjusting the Fixed In Version accordingly.

Could someone who understands the process better than I do update the Status?

Comment 20 Janki 2018-10-12 15:47:11 UTC
*** Bug 1638702 has been marked as a duplicate of this bug. ***

Comment 26 errata-xmlrpc 2018-11-13 23:32:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3614


Note You need to log in before you can comment on or make changes to this bug.