Bug 1566098 - configshell: Fix targetcli create command for args like "cfgstr,par=val" [rhel-7.5.z]
Summary: configshell: Fix targetcli create command for args like "cfgstr,par=val" [rhe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-configshell
Version: 7.5
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Maurizio Lombardi
QA Contact: Martin Hoyer
Marek Suchánek
URL:
Whiteboard:
Depends On: 1559746
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 14:13 UTC by Oneata Mircea Teodor
Modified: 2018-05-14 16:11 UTC (History)
6 users (show)

Fixed In Version: python-configshell-1.1.fb23-4.el7_5
Doc Type: If docs needed, set a value
Doc Text:
Previously, the targetcli utility did not correctly parse command-line options in the "option=value" format or arguments separated by commas. With this update, command-line parsing has been improved, and the options are now recognized correctly.
Clone Of: 1559746
Environment:
Last Closed: 2018-05-14 16:11:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1390 None None None 2018-05-14 16:11:04 UTC

Description Oneata Mircea Teodor 2018-04-11 14:13:40 UTC
This bug has been copied from bug #1559746 and has been proposed to be backported to 7.5 z-stream (EUS).

Comment 4 Sweta Anandpara 2018-05-04 10:17:25 UTC
Tested and verified this on a RHGS cluster having the package python-configshell-1.1.fb23-4.el7_5.

Validated that when a request comes to set a particular key to a value, we are able to successfully set that. Tried it with the key in question (max_data_area_mb). The patch is working as expected. 

Please feel free to move this bug to verified after a round of regression. Thanks!

[root@dhcp47-65 ~]# targetcli ls; targetcli clearconfig confirm=Trueo- / ........................................................................................................ [...]
  o- backstores ............................................................................................. [...]
  | o- block ................................................................................. [Storage Objects: 0]
  | o- fileio ................................................................................ [Storage Objects: 0]
  | o- pscsi ................................................................................. [Storage Objects: 0]
  | o- ramdisk ............................................................................... [Storage Objects: 0]
  | o- user:glfs ............................................................................. [Storage Objects: 1]
  |   o- ob1 ............ [ozone@10.70.47.65/block-store/74a1ac0a-d2ed-4cb5-a555-9a6a23a6576a (1.0MiB) deactivated]
  |     o- alua .................................................................................. [ALUA Groups: 1]
  |       o- default_tg_pt_gp ...................................................... [ALUA state: Active/optimized]
  o- iscsi ........................................................................................... [Targets: 0]
  o- loopback ........................................................................................ [Targets: 0]
All configuration cleared
[root@dhcp47-65 ~]# targetcli ls
o- / ........................................................................................................ [...]
  o- backstores ............................................................................................. [...]
  | o- block ................................................................................. [Storage Objects: 0]
  | o- fileio ................................................................................ [Storage Objects: 0]
  | o- pscsi ................................................................................. [Storage Objects: 0]
  | o- ramdisk ............................................................................... [Storage Objects: 0]
  | o- user:glfs ............................................................................. [Storage Objects: 0]
  o- iscsi ........................................................................................... [Targets: 0]
  o- loopback ........................................................................................ [Targets: 0]
[root@dhcp47-65 ~]# 
[root@dhcp47-65 ~]# 
[root@dhcp47-65 ~]# targetcli /backstores/user:glfs create ob1 1048576 ozone@10.70.47.65/block-store/74a1ac0a-d2ed-4cb5-a555-9a6a23a6576a 74a1ac0a-d2ed-4cb5-a555-9a6a23a6576a control="max_data_area_mb=32"
Created user-backed storage object ob1 size 1048576.
[root@dhcp47-65 ~]# cat /sys/kernel/config/target/core/user_0/ob1/attrib/max_data_area_mb32
[root@dhcp47-65 ~]#
[root@dhcp47-65 ~]# rpm -qa | grep targetcli
targetcli-2.1.fb46-4.el7.noarch
[root@dhcp47-65 ~]# rpm -qa | grep configshell
python-configshell-1.1.fb23-4.el7_5.noarch
[root@dhcp47-65 ~]# rpm -qa | grep rtslib
python-rtslib-2.1.fb63-11.el7.noarch
[root@dhcp47-65 ~]# rpm -qa | grep gluster
glusterfs-client-xlators-3.8.4-54.8.el7rhgs.x86_64
python-gluster-3.8.4-54.8.el7rhgs.noarch
tendrl-gluster-integration-1.5.4-14.el7rhgs.noarch
gluster-nagios-addons-0.2.10-2.el7rhgs.x86_64
glusterfs-libs-3.8.4-54.8.el7rhgs.x86_64
glusterfs-fuse-3.8.4-54.8.el7rhgs.x86_64
libvirt-daemon-driver-storage-gluster-3.9.0-14.el7_5.2.x86_64
glusterfs-events-3.8.4-54.8.el7rhgs.x86_64
gluster-block-0.2.1-14.1.el7rhgs.x86_64
vdsm-gluster-4.17.33-1.2.el7rhgs.noarch
glusterfs-3.8.4-54.8.el7rhgs.x86_64
glusterfs-server-3.8.4-54.8.el7rhgs.x86_64
glusterfs-geo-replication-3.8.4-54.8.el7rhgs.x86_64
glusterfs-rdma-3.8.4-54.8.el7rhgs.x86_64
glusterfs-cli-3.8.4-54.8.el7rhgs.x86_64
gluster-nagios-common-0.2.4-1.el7rhgs.noarch
glusterfs-api-3.8.4-54.8.el7rhgs.x86_64
[root@dhcp47-65 ~]#

Comment 5 Martin Hoyer 2018-05-04 10:21:51 UTC
(In reply to Sweta Anandpara from comment #4)
Thank You!
Our regression tests have not found any issue on RHEL-7.5 with following packages updated:
python-configshell-1.1.fb23-4.el7_5
python-rtslib-2.1.fb63-11.el7_5
targetcli-2.1.fb46-4.el7_5

Comment 10 errata-xmlrpc 2018-05-14 16:11:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1390


Note You need to log in before you can comment on or make changes to this bug.