Bug 1566102 - Detected unhandled Python exception in '/usr/sbin/firewall'
Summary: Detected unhandled Python exception in '/usr/sbin/firewall'
Keywords:
Status: CLOSED DUPLICATE of bug 1526714
Alias: None
Product: Fedora
Classification: Fedora
Component: firewalld
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Eric Garver
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 14:15 UTC by Marco_Anastasio
Modified: 2018-04-11 15:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-11 15:07:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Marco_Anastasio 2018-04-11 14:15:44 UTC
Description of problem:
During startup i noticed a [FAILED] on firewalld. Running journalctl -xe it reports: 

audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=s
systemd[1]: firewalld.service: Unit entered failed state.
systemd[1]: firewalld.service: Failed with result 'exit-code'.
sudo[5943]: pam_unix(sudo:session): session closed for user root
audit[5943]: USER_END pid=5943 uid=0 auid=1000 ses=4 subj=unconfined_u:un
audit[5943]: CRED_DISP pid=5943 uid=0 auid=1000 ses=4 subj=unconfined_u:u
abrt-server[5948]: Deleting problem directory Python3-2018-04-11-16:04:47
abrt-notification[5961]: Process 878 (firewalld) of user 0 encountered an
-- Subject: ABRT has detected an uncaught ModuleNotFoundError exception in firewalld


Steps to Reproduce:
1. sudo systemctl start firewalld3.

Actual results:

Job for firewalld.service failed because the control process exited with error code.
See "systemctl  status firewalld.service" and "journalctl  -xe" for details.


Expected results:
Firewalld service beign started properly



Additional info:
It complaint about a missing "decorator" object

Comment 1 Eric Garver 2018-04-11 15:07:39 UTC

*** This bug has been marked as a duplicate of bug 1526714 ***


Note You need to log in before you can comment on or make changes to this bug.