Bug 1566118 - neutron_tempest_plugin.scenario.test_dvr failed on OVN deployment
Summary: neutron_tempest_plugin.scenario.test_dvr failed on OVN deployment
Keywords:
Status: CLOSED DUPLICATE of bug 1565126
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-neutron-tests-tempest
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Miguel Angel Ajo
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 14:39 UTC by Eran Kuris
Modified: 2018-06-08 12:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-17 13:53:49 UTC
Target Upstream Version:
majopela: needinfo-


Attachments (Terms of Use)

Description Eran Kuris 2018-04-11 14:39:24 UTC
Description of problem:
neutron_tempest_plugin.scenario.test_dvr.NetworkDvrTest.test_vm_reachable_through_compute failed on OVN deployment because it adjusted for neutron ml2/ovs deployment 
{"region_id": "regionOne", "url": "http://172.17.1.17:9292", "region": "regionOne", "interface": "internal", "id": "61b114c6e57e41589912dc1476afab68"}], "type": "image", "id": "3d638edd4dcc4e51a807e5e8df1b590b", "name": "glance"}, {"endpoints": [{"region_id": "regionOne", "url": "http://10.0.0.109:8977", "region": "regionOne", "interface": "public", "id": "19042b8f413140869a4e4c6af2586090"}, {"region_id": "regionOne", "url": "http://172.17.1.17:8977", "region": "regionOne", "interface": "admin", "id": "23ed3af1f1a645fb809dc24eec5dbe1b"}, {"region_id": "regionOne", "url": "http://172.17.1.17:8977", "region": "regionOne", "interface": "internal", "id": "a937510c06c54f65904b56f4cf45f7d2"}], "type": "event", "id": "4b2d4b01179743dab31ac36a55a1a46d", "name": "panko"}, {"endpoints": [{"region_id": "regionOne", "url": "http://10.0.0.109:8042", "region": "r
2018-04-11 01:58:16,834 9949 INFO     [tempest.lib.common.rest_client] Request (NetworkDvrTest:test_vm_reachable_through_compute): 400 POST http://10.0.0.109:9696/v2.0/routers 0.360s
2018-04-11 01:58:16,834 9949 DEBUG    [tempest.lib.common.rest_client] Request - Headers: {'Content-Type': 'application/json', 'Accept': 'application/json', 'X-Auth-Token': '<omitted>'}
        Body: {"router": {"external_gateway_info": {"network_id": "957de0d6-0605-4b60-bf05-53a52d297a99"}, "name": "tempest-router-1759320301", "admin_state_up": true, "tenant_id": "5a779bac7f2b49348f4fba4121c2f903", "distributed": true, "ha": false}}
    Response - Headers: {'status': '400', u'content-length': '116', 'content-location': 'http://10.0.0.109:9696/v2.0/routers', u'date': 'Wed, 11 Apr 2018 05:58:16 GMT', u'content-type': 'application/json', u'connection': 'close', u'x-openstack-request-id': 'req-5f1b131e-d53f-450a-abfb-167485ef6bf2'}
        Body: {"NeutronError": {"message": "Unrecognized attribute(s) 'ha, distributed'", "type": "HTTPBadRequest", "detail": ""}}
}}}

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/neutron_tempest_plugin/scenario/test_dvr.py", line 64, in test_vm_reachable_through_compute
    ha=False)
  File "/usr/lib/python2.7/site-packages/neutron_tempest_plugin/scenario/base.py", line 179, in create_router_by_client
    router = cls.create_admin_router(**kwargs)
  File "/usr/lib/python2.7/site-packages/neutron_tempest_plugin/api/base.py", line 381, in create_admin_router
    *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/neutron_tempest_plugin/api/base.py", line 369, in _create_router_with_client
    admin_state_up=admin_state_up, **kwargs)
  File "/usr/lib/python2.7/site-packages/neutron_tempest_plugin/services/network/json/network_client.py", line 349, in create_router
    resp, body = self.post(uri, body)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 279, in post
    return self.request('POST', url, extra_headers, headers, body, chunked)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 668, in request
    self._error_checker(resp, resp_body)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 779, in _error_checker
    raise exceptions.BadRequest(resp_body, resp=resp)
tempest.lib.exceptions.BadRequest: Bad request
Details: {u'message': u"Unrecognized attribute(s) 'ha, distributed'", u'type': u'HTTPBadRequest', u'detail': u''}

Version-Release number of selected component (if applicable):
osp13   -p 2018-04-10.2 
python2-tempest-18.0.0-2.el7ost.noarch
puppet-tempest-12.4.0-1.el7ost.noarch
openstack-tempest-18.0.0-2.el7ost.noarch
python2-neutron-tests-tempest-0.0.1-0.20180326122805.52449cc.el7ost.noarch
python2-tempestconf-1.1.5-0.20180326143753.f9d956f.el7ost.noarch
puppet-ovn-12.3.1-0.20180221062110.4b16f7c.el7ost.noarch

How reproducible:
always

Steps to Reproduce:
1.run dvr  test on ovn dvr deployment 
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Miguel Angel Ajo 2018-04-11 15:06:42 UTC
Exactly, this test relies on the availability of the "ha" and "distributed" flags of the routers, and the fact that the ml2/ovs creates an snat leg.

I will check if it's possible to rewrite this test in a way that it will be compatible to OVN too.

Comment 3 Eran Kuris 2018-04-15 07:53:21 UTC
Its relevent for those tests too:

neutron_tempest_plugin.api.test_routers.DvrRoutersTest.test_convert_centralized_router

neutron_tempest_plugin.api.test_routers.DvrRoutersTest.test_create_distributed_router

tempest.api.network.test_routers_negative.DvrRoutersNegativeTest.test_router_create_tenant_distributed_returns_forbidden

 neutron_tempest_plugin.scenario.test_dvr.NetworkDvrTest.test_vm_reachable_through_compute

Comment 4 Daniel Alvarez Sanchez 2018-04-17 09:18:27 UTC
@Miguel would this be a dup of: https://bugzilla.redhat.com/show_bug.cgi?id=1565126 ?

Comment 5 Daniel Alvarez Sanchez 2018-04-17 13:53:49 UTC

*** This bug has been marked as a duplicate of bug 1565126 ***


Note You need to log in before you can comment on or make changes to this bug.